LuxRender 1.0 Interface - LuxRender Wiki
Luxrender GPL Physically Based Renderer

LuxRender 1.0 Interface

Personal tools

From LuxRender Wiki

Jump to: navigation, search

Contents

LuxRender 1.2 Interface

LuxRender uses a tabbed interface. The tabs are Render, Queue, Network, and Log. The Render tab is active by default. The Menu and Status bar are always shown, regardless of which tab has been selected.

LuxRender's interface

Menu Bar

The menu bar items are File, Render, View and Help.

File

The File menu contains the following items:

  • Open... - this lets you open a file with the .lxs extension
  • Open Recent - this lets you open a recently rendered scene
  • Resume FLM - this lets you open a .lxs file and it's corresponding .flm file in order to resume rendering of a scene. See How do I continue a render later? for details on resuming a render later.
  • Load FLM - this lets you open a .flm file in order to perform post-processing. It will not perform any rendering.
  • Save FLM - this lets you save the current render to a .flm file which you can use to resume a render or to perform tone mapping later.
  • Export to Image - (version 0.8+) this sub-menu will let you save the current render to a standard image file in several different ways (more details on each option below).
  • Save and Exit - this saves the .flm file then exits the program
  • Exit - this exits the program

Currently LuxRender saves the output at regular intervals into the directory of the .lxs file. This is controlled with settings inside the .lxs file itself and cannot be accessed or controlled within LuxRender itself. You can change the intervals, which image types are written and settings for each image type in the various exporters (like luxblend).

Export to Image

This is a sub-menu under the file menu with the following items:

  • Tonemapped Low Dynamic Range Image... - saves the exact image shown in the GUI (with all tone mapping & other filters applied) to a standard image file. You will be prompted for a file name and format. You can choose from PNG, BMP, JPEG and TIFF image types (note: some additional formats supported by Qt can be specified if you use the proper extension, file type is derived from the extension).
  • Light Groups to Tone mapped LDR Images... - If you have multiple light groups defined then this option will save a separate image for each one. Each group is saved by itself with the specified file name and type. The file names are appended with the name of the specific light group from which it was generated. As before, all tone mapping and other filters are applied for each light group prior to saving.
  • Overlay Statistics - Adds the current render statistics in a black bar across the bottom of the image. This is a toggle option. You must click it again to turn it on or off.
  • High Dynamic Range Image... - saves the photometric responses at each pixel to a floating point OpenEXR file. This preserves more detail in the image (particularly in the shadows and highlights) and is more accurate but the file will be larger and may require special software to view. Tone mapping and other filters are NOT applied when using this option. At present, only OpenEXR format is supported.
  • Light Groups to High Dynamic Range Images... - Similar to the previous option only high dynamic range, OpenEXR files are created without tone mapping and other filters applied.
  • Output HDR Images Tonemapped - All tone mapping and other filters will be applied. This is a toggle option. You must click it again to turn it on or off.
  • Batch Process FLM files... - Use this option to convert a directory of .flm files to images. You are prompted to indicate the input directory containing the .flm files and an output directory to store the generated images. You can select either tone mapped or HDR output and can specify if you want to save individual light groups for each file.

Note: for all of these menu entries (except the 'Batch Process') you must first have a rendering in process or have loaded an existing FLM. When executing a Batch process any rendering in process must first be completely stopped and you will be prompted to save the results before continuing. After a batch process the last FLM processed is loaded into the GUI so any unsaved changes will be lost.

Render

  • Resume - this will resume the rendering process after it has been paused
  • Pause - this pauses the rendering process
  • Stop - this stops the rendering process. If you resume after stopping, the render will restart (instead of continuing).

The functionality of this menu can also be accessed by using the buttons at the top left of the render tab.

View

  • Copy Log - Copies the rendering output, as shown, to the clipboard.
  • Clear Log - Clears the rendering log.
  • Full Screen - Enables full screen mode. Press the hot key (CTRL+ALT+F or CMD+F) to return to normal.
  • Normal Screen - Returns to the normal window mode. Press the hot key (ESC) to return to normal.
  • Overlay statistics - Overlays the rendering statistics on the image in the viewport.
  • Show alpha - Enables alpha transparency in the view port.

Help

  • Online Documentation - This opens up the LuxRender wiki page in your browser.
  • Forums - This opens up the LuxRender forum page in your browser.
  • Gallery - This opens up the LuxRender gallery page in your browser.
  • Bug tracker - This opens up the LuxRender Bug tracker page in your browser so you can submit a bug report if you find an issue.
  • About - This displays a screen with the version of LuxRender you are using, the names of the developers and the address of the LuxRender website.

Render Tab

The render tab contains a preview that shows the current results. By default it is updated regularly. It also contains the side pane (see below).

Depending on mode (see above) pressing the left mouse button in the preview area will either pan the image or zoom in on a rectangle. Pressing the middle mouse button zooms to fit the screen; the mouse wheel zooms in or out; the right mouse button zooms to 100%.

Render Bar

The render bar, below the render tab, provides quick access to resuming, pausing and stopping the rendering, as well as copying the output to clipboard. It also displays how many threads LuxRender is currently using for rendering, and allows you to increment or decrement the number of threads.

Imaging Tab

This tab is a part of the side pane of the render tab. It contains various controls to adjust the post-processing of the rendered image. If the "auto" check box is checked (at bottom) adjusting settings will refresh the image immediately. Otherwise you can press the "Apply" button to force a refresh. The "Reset" button will reset the settings to the values given by the scene file.

The triangle on the right hand side of each title bar allows you to collapse or expand that box. Some boxes such as "Lens Effects" have power buttons which allow you to quickly disable and enable all the effects in that box.

  • Tone Mapping - Allows you to change which tone mapping operator is used and it's parameters. For more information see the Tone Mapping page
  • Color Space - Here you can change the color space settings for the output.
  • Gamma + Film Response - Allows you to change the gamma of the image, and apply camera response files as a tone mapping option.
  • HDR Histogram - Displays a histogram of the output image.
  • Lens Effects - Allows you to apply various lens effects to the image, such as bloom and vignetting. These are best applied when the render is finished, since some are quite time consuming to apply. For more details see the Lens effects page of the manual.
  • Noise Reduction - Allows you to apply noise reduction to the output. As with lens effects it's best to apply these when the render is finished.

Light Groups Tab

LightGroups.png

This tab is a part of the side pane of the render tab. It contains controls to adjust the light group parameters for any light groups in the scene. See the Light Groups page for more information on how to use light groups.

Refine Brush Tab

RefineBrush.png

This tool allows you to specify areas of the image so that LuxRender can concentrate on those areas (usually to decrease or eliminate render noise). See the Refine Brush section of the manual for more details.

Advanced Tab

Advanced.PNG

This tab shows you information being used by LuxRender in the current render.

Queue Tab

This tab allows you to render several scenes and frames of an animation in a queue. You can add/remove scenes and set a halt criterion (number of samples per pixel or time) to continue with the next scene in the queue.

Network Tab

This tab allows you to connect or disconnect network servers, shows you information about any connected servers, and allows you to set the film transmission interval. You can also reset a server, forcing it to abort it's current session and become idle again. See the Network rendering page for more info.

Log Tab

The Log Pane

This tab shows messages that are produced during the loading of scene files and the rendering process, including:

  • Warnings about incorrect usage
  • Information about loaded bitmap images
  • Information about progress of the rendering progress
  • Information about writing output messages

Status Bar

1status bar.png

The status bar, located at the bottom, displays information about the state of your rendering. The individual stats, from left to right:

The first two stats are simply an overall status:

  • Time - The running time of the current render session. (time of previous renders resumed from an .flm file is not counted)
  • Hardware - The number of rendering threads, GPUs, and network nodes currently being used in the render

The next set are the current speed of the local machine. This set (and the preceding one) are visible at all times.

  • Sample count (S/p) - The average number of samples per pixel in the current render buffer. This only counts samples accrued locally during the current run. If there are samples from elsewhere (network rendering of resuming from an flm, those stats are recorded in a later section
  • Sampling rate (S/s) - The average number of samples per second. This is a rolling average of the sampling rate of the past 10 minutes, so it can account for speed changes due to network nodes joining/leaving, other CPU-intensive processes starting up, and so-on.
  • Contribution rate (C/s) - The average number of light "hits" per second. This is derived from the sampling rate value and the efficiency. Since the number of samples a render needs is scene dependent, this value can help you compare overall performance between different scenes or render settings
  • Efficiency (%) - The percentage of samples that are able to "hit" a light source. Path tracing algorithms (the bidirectional and path integrators) are capable of hitting lights more than once per sample, so this value should generally be over 100%.
  • GPU Efficiency - Only appears when using GPU accelerated rendering. This value indicates the percentage of time the GPU(s) is able to be "kept busy" the CPU in charge of feeding it.

The next set of stats are the network statistics. These values are the totals for all nodes in the render farm.

  • Sample count (S/p) - The estimated number of samples per pixel acquired by the network nodes. This is calculated from the sampling rate the network nodes reported when they last returned samples, so it may not be entirely accurate. This is especially true if a node leaves or joins the farm. Generally, changes in render farm performance take one or two refreshes for this value to straighten out.
  • Sampling rate (S/s) - The combined sampling rate off all network nodes, this updated when the nodes "check in" during refresh. The value is a rolling average off all network refreshes in the past 10 minutes (if your network refresh interval is larger than that, it will just be the speed from the previous refreshed)


The last two statistics are another set of sample count and sampling rate values, these two are a summed total of the local + network values, plus samples from a film the render was resumed from, if applicable.

NOTE: Network and total stats do not include efficiency, since this value is the same for all nodes.