LuxRenderDS - LuxRender Wiki
Luxrender GPL Physically Based Renderer

LuxRenderDS

Personal tools

From LuxRender Wiki

Jump to: navigation, search

Contents

LuxRenderDS

LRDS 50 w.png

UNDER CONSTRUCTION

Currently adding content, wiki page created with permission of the author of the LuxRenderDS plugin. Logo above is only a temporary placeholder.

Overview

The LuxrenderDS Plugin is a Luxrender exporter for Daz Studio. Using the plugin, a scene developed in Daz Studio can be exported and rendered by the Luxrender engine. It was developed by "Tofusan", and is currently provided free of charge.

Developer notes:

- This plug-in has not been completed yet. It is likely not to work with stability.

- If you suffer because you used this plug-in, the author doesn't guarantee it. Please use at YOUR OWN RISK.

- Rendering uses the data created through the use of this plugin, please follow the terms of use of 3D model data being used.

- Do NOT redistribute this plug-in.

Please use only if you accept the conditions listed above.

Download & Links

Download

The LuxrenderDS plugin can currently be found at the following link, near the bottom of the page: Download

Additional Links

Forum Discussion: Free DS to Luxrender Link Inside

DeviantArt Group: LuxRenderDS at DeviantArt

Manual

Installation

The zip file contains Daz Studio content files, and two LuxRenderDS.dll files (one for 32 bit OS, and one for 64 bit OS).

1) DLL Files

The appropriate file should be extracted and manually placed in the Daz Studio plugins directory. (e.g. C:\Program Files\DAZ 3D\DAZStudio3\plugins)

2) Content Files

The content files should be extracted to the content directory of your Daz Studio installation. These files contain some samples and presets to use in your scenes.

3) Restart Daz Studio

After restarting Daz Studio, a new Luxrender tab should available under the View -> Tabs -> Luxrender of the Daz Studio interface.

Windows and Tabs

Settings

The settings dialog is accessed via the menu select icon on the top right of the LuxrenderDS Tab.

Lrds 3.jpg

LuxRender Path - Enter the path that the LuxRender executable resides on your computer

Default Output Folder - The default location that the plugin will export the Luxrender files to (.lxs, .lxo, .lxm)

Default Texture Gamma - The default Gamma value which will be used in the LuxRender software

Preview Quality - This setting will change the quality of the texture preview on the Material Tab of the LuxRenderDS plugin

Reduce Memory Consumption - This setting, if enabled, will allow luxRender to use a less memory intensive configuration which is slower but will help to render your image . A must for users of a Win 32 bit system, which limits luxRender to around 2GB of Ram. Also highly recommended for anyone using less than 4GB of Ram.

Overwrite Warning - This setting, if enabled, will cause a warning to appear if the export files already exist in the defined location

LuxRender Tab

The LuxRender tab is the main tab on which all of the following tabs reside. In addition, it has a few options and buttons at the bottom described below.

Lrds 9.jpg

Material

The Material tab is the first tab on the LuxRenderDS Plugin tab.

Lrds 8.jpg

Volume

The Volume tab is the second tab on the LuxRenderDS Plugin tab.

Lrds 7.jpg

Refresh Volume List Refreshes Volume list above, and will reflect any changes made.

Add New - Will Add a New Volume to the Volume list above.

Remove To Remove a Volume in the Volume list above left click on Volume name and then press Remove.

Volume Type - LuxRender includes a flexible, powerful volume system that controls how light behaves when it moves through objects or the space in-between objects. - Clear is a simple volume that features refraction and absorption but no scattering. It is primarily meant to be used with clear materials, in particular the glass materials. It takes an index of refraction and an absorption color. To read the rest of the discription, follow link [1]

- The homogeneous volume represents a volume with an even distribution of microscopic particles. When used as an interior volume, it can be used for sub-surface scattering (SSS), cloudy liquids, or rendering an object as smoke (like the example above). It can also be used as the world volume, which will enable atmospheric scattering. To read the rest of the discription, follow link [2]

Name - This function is used in combanation with the Volume List, Add New and Rename functions. Choose a Volume name in the Volume List so that it becomes highlighted. If there are no Volume names in the Volume list or you want to keep the one's that are there, you'll need to add a new volume by pressing the "Add New". Again make sure that the Volume name is highlighted in the Volume List. Type your new name into the "Name" feild then press "Rename" this will then add the new Volume name to the Volume list.

Rename - Choose the Volume you wish to rename from the Volume list above. Its name will appear in the "Name" field, highlight the name and delete or just start typing new name. Press Rename and it will add the New Volume to the Volume list above.

The following Options will only appear when you have choosen a Volume in the Volume list

Absorption - Color - To read the discription, follow link and look under "Absorption Color" [3]

- Scale - To read the discription, follow link and look under "Absorption Color" [4]

Complementary Color - On - Information needed.


Index of Refraction - To read the rest of the discription, follow link and look under "Index of Refraction" [5]

Gamma - Information needed.

Light

The Light tab is the third tab on the LuxRenderDS Plugin tab.

Lrds 6.jpg

This tab allows you to introduce IBL or Image Based Lighting into your scene. LuxRender documentation refers to this feature as Environment Maps. More information about this caqpability in LuxRender can be found in this Wiki in the Lighting or Environment Map sections. It is recommended to familiarize yourself with this information before proceeding!

To create a light, press the "Add IBL Light" button found in the middle of the tab. A new light named "Luxrender IBL" will be created. If selected, options for configuring the light will appear below.

A proper Environment Map (or image) should be selected for the scene, and can be inserted via the Texture selection box. [6]

NOTE: The Environement Map or image selected will show up in the background of the image, unless "Output Alpha Channel" is selected when generating the image. In this case, the Pre-Multiply Alpha setting found on the Render tab may be important to set/use, if needed. [7]

Mapping - Select either Angular Mapped, Latitude/Longitude or Vertical Cross projection for your images

Gamma - This sets the default Gamma for the corresponding light or light group [8]

Color - This value sets the default color for the light group, which is set in LuxRender as the "RGB" color [9]

Temperature - This value sets the default color for the light group, which is set in LuxRender as the "Black Body Temperature" [10]

Intensity - This sets the default Gain for the corresponding light or light group [11]

Intensity Scale - (?) A setting of 100% is default.

Light Group - To change the light group name, just modify this field. More information about light groups can be found in the LuxRender Light Groups section of the Wiki

Importance - (?) Importance seems to be a comparative setting. From the Forums: "If you have a factor 10 between the importance factors, the integrator will sample one light 10 times more often than the other. This might obviously create more noise for those lights, but as long as they don't contribute much to the total illumination this should remain unnoticeable. However if you turn off the light groups that are dominant, this noise will become much more noticeable."

Render

The Render tab is the fourth tab on the LuxRenderDS Plugin tab.

Lrds 5.jpg

Output folder - Left click on the Select button and enter folder path you wish to save files to

Output Name - Enter name of file you wish to save

Image Format - This setting, if enabled, will save your final render to the preferred file format- PNG, TGA, OpenEXR -

Alpha Channel - This setting, if enabled, will create an alpha channel and can be used for objects or complex scene. Allowing for further postwork to be done in photo editing software.

Pre Alpha Channel - This setting, if enabled, the PreMultiply Alpha option removes unwanted halos from Alpha Channels enabling better postwork blending.

LDR Clamp Method - Color Clamping options can be set here for Lum-Hue-Cut - [12]

Write *.flm for resume - This setting, if enabled, creates a LuxRender Film file (*.flm) enables you to resume rendering a previously rendered file.

Halt on S/p - Halt S/p adds a samples per pixel stop value. will stops the render when the nominated value of samples per pixel is reached. eg. Setting the value to 100, will stop LuxRender when it reaches 100 samples per pixel.

Halt on Time(sec) - Halt on Time(sec) adds a time stop value. eg. Halt on Time will stops the render when the nominated value in seconds is reached. Setting the value to 100, will stop LuxRender when it reaches 100 seconds.

If both Halt on S/p & Halt on Time values are set, LuxRender will stop at whichever of these two processes happens first. If both are left at their default value of zero, LuxRender will continue Rendering until it is manually stopped by the user.

World Volume - Default values can be set for interior and exterior volume - Check out the following link under "What render settings should I use?"[13]

Render Preset - Recommended Settings - [14] - Overview of Render Engine settings - For Advanced Users - [15]

Volume Integrator - The volume integrator handles calculation of light paths through volumes. Details for Muti, Single and Emission settings can be found under 5. Volume Integrator in the following link http://www.luxrender.net/wiki/LuxRender_Render_settings

Reduce Memory Consumption - This setting, if enabled, will allow luxRender to use a less memory intensive configuration which is slower but will help to render your image . A must for users of a Win 32 bit system, which limits luxRender to around 2GB of Ram. Also highly recommended for anyone using less than 4GB of Ram.

Export with Textures - This setting, if enabled, will export all image maps as well as the LuxRender files. This allows the user to continue a render on another computer that does not have access to your Daz runtime files.

Tools

The Tools Window is the last tab on the LuxRenderDS Plugin tab.

Lrds 4.jpg

Version - Displays the currant version number of the LuxRenderDS Plugin

Initial Setup of All Materials - Important Step - This button will transfer and setup all current material data from Daz Studio to the LuxRenderDS Plugin. Otherwise when your scene is rendered, the material will be missing and the objects in the scene will all appear white. If objects or lights have been added to the scene in Daz Studio after the Initial Setup of All Materials was first pressed, it will need to be pressed agian, or else the changes made will not take effect. Other symptoms of needing to press the Initial Setup of All Materials again is not being able to change a material in the Materials Tab or not being able to find all the options when trying to change a material.

Remove All LuxRender Settings - Will remove all LuxRender settings

Create Instance - When working on a scene with mutiply copies of the same object, creating Instances will help reduce memory usage. Creating Instances makes a virtual copy or copies of your selected object. You must have your object selected and then in the LuxRenderDS Tool tab press "Create Instance". The following dialog Box will appear.

Create Instance dialog.jpg

Count - Adding a number in the X, Y or Z fields will create that number of copies along each of corresponding axes.

Delta - Adding a number in the X, Y or Z fields will create space between your Instances along the corresponding axes. The units are mesured in centimeters, so 10 will equal to 10cm and 100 is equal to a 100cm or 1 meter.

Randomize Y rotate - Rotates Instances randomly horizontally, but will not effect Instances vertically.

Accept - When you are happy with the settings press Accept. Once Accepted Daz Studio will process and create the Instances in your Daz sence. Each of the instances are represented by the red, blue & green 3d axes. When you render your scene in LuxRender your Instances will appear as they should.

Cancel - Stops the opperation.

Tutorials

Quick Setup and Usage

1) On the Luxrender Tab, choose "Settings..." on the option menu (little triangle at the top right of the section) to set the LuxRender installation path, the default export folder and other overall settings (see more information in the Detailed Usage section below)

Lrds 1.jpg

2) Compose a Scene in Daz Studio

3) Press "Initial Setup of All Materials and Lights" button on Tools page. (NOTE: If you added any figures/props/lights in the scene, then you must press this button again before rendering)

Lrds 2.jpg

4) Change parameters of any materials/lights, if needed

5) Press "Render" button on the Render tab, which will start LuxRender and begin the render process

NOTE: All parameters are stored in the daz native format scene file (*.daz)

Advanced Tutorial

A more advanced step-by-step tutorial was written by user "michaeltoo", and can be found via this link: LuxRender_Quick_Start_Tutorial

Tips & Tricks

- If you want to use the "Water" material, then you must specify the appropiate volume to material's Interior. This is because, "Water" is the material with a displacement mapped on Glass2.

Development

Change Log

Jun 9, 2011 - Version 0.7.0.0

Jun 10, 2011 - Version 0.7.0.1 Fixed: Used the VC2008 runtime debug version.

Jun 13, 2011 - Version 0.7.1.0 Fixed: Output folder select button was no effect. Fixed: Problem when Output folder is empty. Added: Complementary Color on Absorption. Added: World Volume on Render page. Added: Volume Integrator selection. Changed: Default Volume Integrator "multi" to "single". Added: SPPM rendering preset (Requires LuxRender SPPM build) Fixed: When changing material type, automatic set the color and texture from DAZ Material.

Jun 18, 2011 - Version 0.7.2.2 Added: New feature: Object Instance. Fixed: Paste bug. Fixed: Parameter refresh when Paste executed.

Jun 18, 2011 - Version 0.7.2.4 Changed: Default Accelerator: tabreckdtree to kdtree. Added: New Option: Reduce Memory Consumption (qbvh Accelerator)

Jun 19, 2011 - Version 0.7.2.5 Fixed: Emission problem.

Jun 20, 2011 - Version 0.7.2.6 Added: Render preset: Hybrid OpenCL Fixed: Sun light settings not saved.

Jun 25, 2011 - Version 0.7.2.7 Added: IES profile on Point light and Mesh light.

Jun 27, 2011 - Version 0.7.2.9 Fixed: IBL gain Added: Script for making IBL preset.

Jul 2, 2011 - Version 0.7.2.10 Added: Texture Gamma Added: x64 build (Test)

Jul 4, 2011 - Version 0.7.2.11 Fixed: Gamma problem when copy/paste materials.

Jul 6, 2011 - Version 0.7.2.12 Fixed: Default value of the texture gamma: 2.2 to 1.8 Added: Default Texture Gamma on Settings dialog. Added: Texture optimize before render/export.

Jul 8, 2011 - Version 0.7.2.13 Fixed: Displacement direction problem. Fixed: Subdivision surface parameters problem when copy/paste. Added: Overwrite warning. (It can be disabled in Settings dialog.) Added: emission and displacement in null material. Added: Gamma on emission imagemap.

Jul 9, 2011 - Version 0.7.2.14 Fixed: Crash when material not assigned.

Jul 10, 2011 - Version 0.7.2.15 Fixed: Emission texture problem.

Jul 12, 2011 - Version 0.7.3.1 Fixed: Default value of the texture gamma: 1.8 to 2.2 Fixed: Remove clamp of emission gain. Added: New property: Reverse Normal. (for sky dome) Added: DAZ Script interface. Added: Some material script for V4/M4.

Jul 16, 2011 - Version 0.7.3.2 Added: Inverse gamma collection for linearized RGB color.

Jul 17, 2011 - Version 0.7.3.3 Fixed: Some minor bugs. Fixed: Material preset. Added: New option into Render tab: Export with textures.

Jul 22, 2011 - Version 0.7.3.4 Fixed: Material preview size. Fixed: Asymmetry of homogeneous volume. Fixed: label name of "Setup all materials and lights" button. Added: "Quality of material preview" in Settings dialog. Added: New script: UberEnvironment2 to LuxRender.

Aug 1, 2011 - Version 0.7.3.5 Fixed: Material preview algorithm.

Aug 7, 2011 - Version 0.7.3.6 Fixed: Mix material bug.

Aug 13, 2011 - Version 0.7.3.7 Fixed: Camera angle bug. Fixed: Work on ShaderMixer Brick material.

Sep 3, 2011 - Version 0.7.3.8 Fixed: It can be specify multiple output image format in Render tab. Added: New option into Render tab: PreMultiply Alpha.

Sep 5, 2011 - Version 0.7.3.9 Added: Light power (Watts) on Area Light. Added: Luminous efficacy (lm/W) on Area Light.