LuxRender Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001574LuxRenderLuxMax integratedpublic2015-05-27 14:262016-04-06 10:18
ReporterTAO 
Assigned Tohedphelym 
PrioritynormalSeverityminorReproducibilityalways
StatusresolvedResolutionfixed 
Platform3dsmax 2015OSwindowsOS Version8.1
Product Version1.4 
Target VersionFixed in Version 
Summary0001574: Any high poly object can cause problem in render
DescriptionAny high poly object can cause black triangles and unwanted extra polygons in render image
and sometime some part of object detach from each other.
TagsNo tags attached.
Mercurial Changeset #
Requires Documentation UpdateNo
Requires Exporter UpdateLuxMax
Attached Filesjpg file icon HighPoly.jpg [^] (280,628 bytes) 2015-05-27 15:50

- Relationships

-  Notes
(0004239)
hedphelym (developer)
2015-05-27 15:28
edited on: 2015-05-27 15:31

Could you provide a zipped sample scene?
So that I know I'm debugging the exact same issues as you describe?
And maybe a example render also, so that I can compare with my results.

(0004240)
TAO (developer)
2015-05-27 15:53

i add a render sample that show the issues i describe as you can see in image there is just a teapot with 64 segments without smooth option.
(0004241)
hedphelym (developer)
2015-05-27 16:03

Thanks, when I turn off the 'smooth' option in the mesh I get the same issue, but when 'smooth' enabled it renders fine as high poly.

I'm not sure exactly what is going on, but I'll keep an eye on it and debug.
(0004242)
TAO (developer)
2015-05-27 16:10

remember that if smooth option are enable still you can see this issue but with larger number of segments
for example
60 segments without smooth
64 segments even with smooth or if you add more segment with turbo smooth
so problem exist all the time smooth option make it less visible.
(0004316)
hedphelym (developer)
2016-03-31 12:52

Fixed, it was floating error in the hashing code that caused it, so that has been disabled now.
(0004317)
hedphelym (developer)
2016-04-02 12:28

Reopening this one, I know what the issue is, and I thought I had it fixed, but it turns out the fix caused new issues, so I have reverted the previous fix, and reopened this task.

I'll look into it again.
(0004318)
hedphelym (developer)
2016-04-06 10:18

Fixed.

- Issue History
Date Modified Username Field Change
2015-05-27 14:26 TAO New Issue
2015-05-27 15:28 hedphelym Note Added: 0004239
2015-05-27 15:31 hedphelym Note Edited: 0004239 View Revisions
2015-05-27 15:31 hedphelym Assigned To => hedphelym
2015-05-27 15:31 hedphelym Status new => assigned
2015-05-27 15:50 TAO File Added: HighPoly.jpg
2015-05-27 15:53 TAO Note Added: 0004240
2015-05-27 16:03 hedphelym Note Added: 0004241
2015-05-27 16:10 TAO Note Added: 0004242
2016-03-31 12:52 hedphelym Note Added: 0004316
2016-03-31 12:52 hedphelym Status assigned => resolved
2016-03-31 12:52 hedphelym Resolution open => fixed
2016-04-02 12:28 hedphelym Note Added: 0004317
2016-04-02 12:28 hedphelym Status resolved => feedback
2016-04-02 12:28 hedphelym Resolution fixed => reopened
2016-04-06 10:18 hedphelym Note Added: 0004318
2016-04-06 10:18 hedphelym Status feedback => resolved
2016-04-06 10:18 hedphelym Resolution reopened => fixed


Copyright © 2000 - 2017 MantisBT Team
Powered by Mantis Bugtracker