LuxRender Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001124LuxRenderCorepublic2011-07-28 09:222012-09-11 09:10
Reporterskrat 
Assigned Tojeanphi 
PrioritynormalSeveritycrashReproducibilityalways
StatusclosedResolutionunable to reproduce 
Platformi386, x86_64OSMacOSOS Version10.6.6
Product Version0.8 
Target Version1.0Fixed in Version1.0RC4 
Summary0001124: Exphotonmap crash
DescriptionWith both 0.8 release and 0.9-dev, it also happens with IGI.
Steps To ReproduceRun attached scene
Additional InformationThread 2 Crashed:
0 liblux.dylib 0x00000001002a0599 lux::PhotonMapPreprocess(lux::RandomGenerator const&, lux::Scene const&, std::string const*, lux::BxDFType, lux::BxDFType, unsigned int, unsigned int, lux::RadiancePhotonMap*, unsigned int, lux::LightPhotonMap*, unsigned int, lux::LightPhotonMap*, unsigned int) + 8729
1 liblux.dylib 0x000000010035cfde lux::ExPhotonIntegrator::Preprocess(lux::RandomGenerator const&, lux::Scene const&) + 622
2 liblux.dylib 0x00000001003b1753 lux::SamplerRenderer::Render(lux::Scene*) + 883
3 liblux.dylib 0x00000001001eb0f8 lux::Context::WorldEnd() + 984
4 liblux.dylib 0x000000010019ffe6 yyparse() + 12454
5 liblux.dylib 0x00000001001a70b0 parseFile(char const*) + 192
6 liblux.dylib 0x00000001001a7219 luxParse + 25
7 org.luxrender.luxrender 0x0000000100052ece boost::program_options::typed_value<int, char>::xparse(boost::any&, std::vector<std::string, std::allocator<std::string> > const&) const + 50558
8 org.luxrender.luxrender 0x0000000100060f15 boost::detail::thread_data<boost::_bi::bind_t<void, boost::_mfi::mf1<void, MainWindow, QString>, boost::_bi::list2<boost::_bi::value<MainWindow*>, boost::_bi::value<QString> > > >::run() + 85
9 liblux.dylib 0x00000001005fd194 thread_proxy + 132
10 libSystem.B.dylib 0x00007fff83ab4536 _pthread_start + 331
11 libSystem.B.dylib 0x00007fff83ab43e9 thread_start + 13

Thread 2 crashed with X86 Thread State (64-bit):
TagsNo tags attached.
Mercurial Changeset #
Requires Documentation UpdateNo
Requires Exporter Update
Attached Fileszip file icon out.lxs.zip [^] (766,628 bytes) 2011-07-28 12:34

- Relationships

-  Notes
(0003127)
J the Ninja (developer)
2011-07-28 12:28

You forgot to attach the scene ;)
(0003128)
skrat (reporter)
2011-07-28 12:35

Here it comes, it's from custom exporter, there are certainly issues with it (QBVH accelerator complains)
(0003134)
J the Ninja (developer)
2011-08-02 18:20
edited on: 2011-08-02 18:33

I can't reproduce the crash here. Your texture aren't included, obviously, so its possible the error is caused by one of them? Can you try rendering without them, and see if that fixes the error?

(0003136)
skrat (reporter)
2011-08-03 06:08

I tried that, same error, I get this with both 0.9-dev build from forums, and my own build. I'm not sure where to got from here. Still crashes in

lux::ExPhotonIntegrator::Preprocess(lux::RandomGenerator const&, lux::Scene const&) + 413

no matter what I do with settings. Seg.fault or Bus error
(0003179)
jeanphi (administrator)
2011-09-04 15:55

I can't reproduce the issue either on Linux so I guess it is fixed or caused by your textures.
Can you try with the very latest sources?
(0003182)
skrat (reporter)
2011-09-05 06:06

Hi jeanphi,
I abandoned LuxRender because of performance issues, it turned out that speed is more important for the project, than physical correctness. And I wasn't able to get de-noised image out of LuxRender under 10 minutes. Thanks for the effort though, wish you good luck.
(0003183)
jeanphi (administrator)
2011-09-05 08:18

Best of luck with your project skrat, maybe you'll be able to use LuxRender on another one.
I'm resolving the issue since we can't reproduce it and it seems you won't be able to provide more information.
Please reopen if you have more evidences.

- Issue History
Date Modified Username Field Change
2011-07-28 09:22 skrat New Issue
2011-07-28 12:28 J the Ninja Note Added: 0003127
2011-07-28 12:34 skrat File Added: out.lxs.zip
2011-07-28 12:35 skrat Note Added: 0003128
2011-08-02 18:20 J the Ninja Note Added: 0003134
2011-08-02 18:33 J the Ninja Note Edited: 0003134 View Revisions
2011-08-03 06:08 skrat Note Added: 0003136
2011-08-31 08:17 jeanphi Target Version => 1.0
2011-08-31 08:32 jeanphi Assigned To => jeanphi
2011-08-31 08:32 jeanphi Status new => assigned
2011-09-04 15:55 jeanphi Note Added: 0003179
2011-09-04 15:55 jeanphi Status assigned => feedback
2011-09-05 06:06 skrat Note Added: 0003182
2011-09-05 06:06 skrat Status feedback => assigned
2011-09-05 08:18 jeanphi Note Added: 0003183
2011-09-05 08:18 jeanphi Status assigned => resolved
2011-09-05 08:18 jeanphi Fixed in Version => 1.0
2011-09-05 08:18 jeanphi Resolution open => unable to reproduce
2012-08-21 09:54 jeanphi Fixed in Version 1.0 => 1.0RC4
2012-09-11 09:10 jeanphi Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker