LuxRender Bug Tracker

View Issue Details Jump to Notes ] Issue History ] Print ]
IDProjectCategoryView StatusDate SubmittedLast Update
0001031LuxRenderCorepublic2011-04-18 04:152012-09-11 09:11
ReporterReggie68 
Assigned Tojeanphi 
PrioritynormalSeverityminorReproducibilityalways
StatusclosedResolutionsuspended 
PlatformOSOS Version
Product Version0.8RC3 
Target Version1.0Fixed in Version1.0RC4 
Summary0001031: Null Material Visible in Render
DescriptionTest scene with a cube of Null material. With bi-dir the cube is visible in the render.
Have also had the problem with hybrid renderer.
Steps To ReproduceScene Files available in attached file
TagsNo tags attached.
Mercurial Changeset #
Requires Documentation UpdateNo
Requires Exporter Update
Attached Fileszip file icon Null_Test.zip [^] (2,404 bytes) 2011-04-18 04:15
zip file icon Null_Test2.zip [^] (54,964 bytes) 2011-04-22 04:21
zip file icon Null_Test4.zip [^] (2,469 bytes) 2011-05-09 10:21

- Relationships

-  Notes
(0002961)
Reggie68 (reporter)
2011-04-22 04:21

Added correct version of scene files.
(0003011)
Reggie68 (reporter)
2011-05-09 10:22

Just for fullness, added test scene with simple cube.
(0003165)
J the Ninja (developer)
2011-09-01 00:04

You're running out of bounces. Watch what happens when you change the values for eye depth and light depth in the lxs. With 4/4 the cube looks like it has absorption turned on. With 96/96 it's invisible.
(0003166)
Reggie68 (reporter)
2011-09-01 02:02

You are mis-understanding the issue which has now moved on with the addition of bi-dir hybrid.

If I generate a scene and render by bi-dir (non-hybrid), I should get the same result if I then render using the bi-dir hybrid method.

With this scene I don't. I should not have to make changes to scene geometry or the way light interacts with the scene to use either method.
(0003167)
J the Ninja (developer)
2011-09-01 02:15

Wait, what? That's not the issue that you describe above. After some searching, I found this thread: http://www.luxrender.net/forum/viewtopic.php?f=16&t=5912&p=61624&hilit=null+visible#p61624 [^]

In that thread as well, you describe the issue was the cube always being visible. Passing through the null mat consumes a bounce, that can cause the ray to be terminated so that the null mat looks is visible to that ray as a black surface. If some rays die on the surface, and some don't, it will appear as ghostly. Considering the severity of the issue in test4 can literally be changed by adjusting the path depth, I'd say 25/25 isn't enough for that scene.

IIRC, Dade said hybrid bidir won't trace shadow rays through null (yet), which might account for this being worse with it.
(0003168)
J the Ninja (developer)
2011-09-01 02:49

FWIW, I can reproduce the issue at 96/96 with hybrid bidir, but hybrid bidir is unfinished and has a lot of bugs. Expecting it to behave exactly like regular bidir isn't really reasonable at this point.
(0003170)
jeanphi (administrator)
2011-09-01 02:57

If the issue is only with hybrid bidir and not regular bidir it can be resolved. Null materials are not correctly handled by hybrid bidir yet, that's a known issue due to the unfinished state of hybrid bidir.
(0003172)
Reggie68 (reporter)
2011-09-01 04:34

That's fair enough and understood. This was reported prior to the 0.8 release (was introduced in RC3) and hadn't been updated by a developer for three months, 0.9 has brought in hybrid bi-dir and the issue arose there as well.

It was also noted here with reference to an early 0.9 release:
http://www.luxrender.net/forum/viewtopic.php?f=30&t=6636&start=10#p68457 [^]

The point of the test with a 0.9 weekly was to see if a null material performed in a similar fashion with hybrid bi-dir as it does with classic bi-dir, which it didn't. As that is due to a known issue then that is a suitable response and the issue can be left until hybrid is finished. Changing the test parameters to produce a better result defeats the whole point of a test methodology.
(0003173)
jeanphi (administrator)
2011-09-01 07:44

I'll have a look at it and resolve the issue is the behaviour is the expected one with standard bidir. I'll leave it open and I'll try to fix it otherwise.
(0003174)
Reggie68 (reporter)
2011-09-01 10:43

IIRC, the bi-dir render gives me the expected result with the cube being invisible as it is a null in a simple scene. In hybrid bi-dir, it shows up with distortion in the lower surface as per the image in the 0.9 thread.

Given the current state of hybrid, that is expected. Maybe the incident should be closed until hybrid bi-dir is more mature.
(0003175)
jeanphi (administrator)
2011-09-01 11:33

Per Reggie68 last comment, that's a known of hybrid bidir issue due to it not being finished.

- Issue History
Date Modified Username Field Change
2011-04-18 04:15 Reggie68 New Issue
2011-04-18 04:15 Reggie68 File Added: Null_Test.zip
2011-04-22 04:21 Reggie68 File Added: Null_Test2.zip
2011-04-22 04:21 Reggie68 Note Added: 0002961
2011-05-09 10:21 Reggie68 File Added: Null_Test4.zip
2011-05-09 10:22 Reggie68 Note Added: 0003011
2011-05-24 15:55 jeanphi Target Version => 1.0
2011-08-31 08:54 jeanphi Assigned To => jeanphi
2011-08-31 08:54 jeanphi Status new => assigned
2011-09-01 00:04 J the Ninja Note Added: 0003165
2011-09-01 02:02 Reggie68 Note Added: 0003166
2011-09-01 02:15 J the Ninja Note Added: 0003167
2011-09-01 02:49 J the Ninja Note Added: 0003168
2011-09-01 02:57 jeanphi Note Added: 0003170
2011-09-01 04:34 Reggie68 Note Added: 0003172
2011-09-01 07:44 jeanphi Note Added: 0003173
2011-09-01 10:43 Reggie68 Note Added: 0003174
2011-09-01 11:33 jeanphi Note Added: 0003175
2011-09-01 11:33 jeanphi Status assigned => resolved
2011-09-01 11:33 jeanphi Fixed in Version => 1.0
2011-09-01 11:33 jeanphi Resolution open => suspended
2012-08-21 09:54 jeanphi Fixed in Version 1.0 => 1.0RC4
2012-09-11 09:11 jeanphi Status resolved => closed


Copyright © 2000 - 2014 MantisBT Team
Powered by Mantis Bugtracker