render suddenly dark

Please use this forum for general user support and related questions.

Moderator: coordinators

Forum rules
Please include your operating system type/version, LuxRender version and Exporter version used when submitting a support post.

Make sure you have read the Release forum thread for Release and RC (Release Candidates) builds as these threads contain information on known problems and workarounds: Test Builds Forum

render suddenly dark

Postby EvilTwin » Fri Feb 24, 2012 7:22 pm

hi
first of all: im not really experienced with luxrender
this is my first shot at a "full" scene
until 2 days ago everything went fine and i got (wip)results like this:

Image

but as of today all luxrender is showing me is a dark image with some bright spots
i got no idea what i could have done
if anyone could be so kind to look at my scene and see if there is anything terribly wrong,
it would really help me a lot
btw: im using blender luxrender 0.8
and im JUST realizing that my linux distro upgraded blender to 2.62 today
of course i copied the luxblend-addon to the new 2.62 folder and my material previews also display fine

conclusion: i have NO idea what is different =/
any help appreciated

thx
Attachments
lightbulb-non-bmesh.blend
scene file
(3.15 MiB) Downloaded 28 times
EvilTwin
 
Posts: 17
Joined: Wed Oct 06, 2010 7:39 am

Re: render suddenly dark

Postby SATtva » Fri Feb 24, 2012 11:15 pm

Are you using Reinhard tonemapper by a chance? Then simply switch to Linear or Autolinear. If you're interested in knowing the differences between these algorithms, then look up the wiki.
Linux builds packager
聞くのは一時の恥、聞かぬのは一生の恥
User avatar
SATtva
Developer
 
Posts: 5931
Joined: Tue Apr 07, 2009 12:19 pm
Location: from Siberia with love

Re: render suddenly dark

Postby J the Ninja » Fri Feb 24, 2012 11:34 pm

EvilTwin wrote:btw: im using blender luxrender 0.8
and im JUST realizing that my linux distro upgraded blender to 2.62 today
of course i copied the luxblend-addon to the new 2.62 folder and my material previews also display fine


There's your issue. 2.62 changes some things in the way object transforms are exported, so you'll need an updated version of luxblend. You can get an updated luxblend from here: https://bitbucket.org/luxrender/luxblend25/get/tip.zip

If you had a pylux module in your old luxblend folder, you can just copy that into the new one.




....and now that i think about it, it's odd that no one has complained of this until now. Suggests the dev versions are being used more than the stable ones?
-Jason

Material DB Admin
User avatar
J the Ninja
Developer
 
Posts: 2432
Joined: Wed May 19, 2010 9:54 pm
Location: Portland, USA

Re: render suddenly dark

Postby EvilTwin » Sat Feb 25, 2012 7:16 am

@SATtva:
yes i was using linear all along

@J
thanks
but that actually made it worse :D
i now have no material previews anymore + the render doesn't even start
and when i try to load the exported file manually lux just says "Missing WorldEnd in scenefile 'lightbulb-non-bmesh.Scene.00002.lxs'"
after i realized the luxblend version was 0.9-dev i got the latest weekly linux builds of lux but that made no difference

here are my settings
Image
EvilTwin
 
Posts: 17
Joined: Wed Oct 06, 2010 7:39 am

Re: render suddenly dark

Postby Meelis » Sat Feb 25, 2012 11:21 am

Scene is very large, not in reall world scale.
Walls are fishy, no thickess (just intersecting single faces).
User avatar
Meelis
 
Posts: 926
Joined: Sat Oct 17, 2009 2:16 am

Re: render suddenly dark

Postby EvilTwin » Sat Feb 25, 2012 11:30 am

Meelis wrote:Scene is very large, not in reall world scale.
Walls are fishy, no thickess (just intersecting single faces).


okay
is there some kind of factor how many cm/m a blender unit is?
and i first had real walls with thickness in, but the results were the same with these planes
EvilTwin
 
Posts: 17
Joined: Wed Oct 06, 2010 7:39 am

Re: render suddenly dark

Postby SATtva » Sat Feb 25, 2012 11:49 am

is there some kind of factor how many cm/m a blender unit is?

1 Blender Unit (BU) = 1 m.
Linux builds packager
聞くのは一時の恥、聞かぬのは一生の恥
User avatar
SATtva
Developer
 
Posts: 5931
Joined: Tue Apr 07, 2009 12:19 pm
Location: from Siberia with love

Re: render suddenly dark

Postby EvilTwin » Sat Feb 25, 2012 11:58 am

SATtva wrote:1 Blender Unit (BU) = 1 m.

thx, fixed it
but still
this wasn't the source of my problem
otherwise i wouldn't have been able to render anything in the first place
EvilTwin
 
Posts: 17
Joined: Wed Oct 06, 2010 7:39 am

Re: render suddenly dark

Postby Meelis » Sat Feb 25, 2012 12:31 pm

Did you fix floor and wall, they didnt have any thickness (faces are doublesided but still in case).
After you scaled scene smaller, did you "ctrl + a -> aplly scale" for all meshes?
User avatar
Meelis
 
Posts: 926
Joined: Sat Oct 17, 2009 2:16 am

Re: render suddenly dark

Postby J the Ninja » Sat Feb 25, 2012 12:52 pm

The material "Plastik-Weiss" has a texture assigned to it which doesn't exist (Tapete, the texture is called Tapete.001). That fixes the issue with the 0.9 plugin.
-Jason

Material DB Admin
User avatar
J the Ninja
Developer
 
Posts: 2432
Joined: Wed May 19, 2010 9:54 pm
Location: Portland, USA

Next

Return to LuxRender User Support

Who is online

Users browsing this forum: Yahoo [Bot] and 0 guests

cron