LuxRender v1.5RC1 release

News & Announcements regarding releases, features, exporters and project coordination.

Moderators: Dade, coordinators

Re: LuxRender v1.5RC1 release

Postby carlosa » Sun Jun 21, 2015 7:40 am

Great,
Thanks !!
User avatar
carlosa
 
Posts: 35
Joined: Wed May 30, 2012 7:19 am

Re: LuxRender v1.5RC1 release

Postby J the Amateur » Sun Jun 21, 2015 7:43 am

I'm using Windows 7 under both Blender 2.74 and the 2.75RC2. Both show the same issue. I've also noticed the following error in the log window when I switch to LuxCore mode (classic Lux API seems to work fine)

Preview aborted: Render interrupted
Starting preview render
Rendering aborted: name "BlenderSceneConverter" is not defined
It then prints a traceback to the _init_.py file at line 1655

I've seen this before when I had the Mitsuba and Appleseed exporters enabled, as both borrow heavily from LuxBlend and caused some code conflicts when all three were enabled at the same time. I have those exporters in my 2.74 folder but neither are enabled currently. I don't have them in the 2.75RC2 folder.

Edit: I've tried both manually copying and installing from the .zip. I even deleted all the blender data from my AppData system folder...... Nothing changes the behavior.
"Giggidy"
J the Amateur
 
Posts: 63
Joined: Sat Mar 05, 2011 6:59 pm

Re: LuxRender v1.5RC1 release

Postby B.Y.O.B. » Sun Jun 21, 2015 7:58 am

J the Amateur wrote:Preview aborted: Render interrupted
Starting preview render
Rendering aborted: name "BlenderSceneConverter" is not defined

This sounds like your LuxBlend is outdated (maybe an old version accidentally got packaged? Which 1.5RC1 package did you download?)
Try using the latest from the link in my signature (you'll have to go into the zip, open the "src" folder and copy the "luxrender" folder in there to the Blender addon directory).
User avatar
B.Y.O.B.
Developer
 
Posts: 5049
Joined: Wed Nov 10, 2010 4:10 pm
Location: Germany

Re: LuxRender v1.5RC1 release

Postby J the Amateur » Sun Jun 21, 2015 8:05 am

I downloaded from the "1.5 rc1" link on the main page. Windows non OpenCL version 64 bit. I extracted the LuxBlend folder that the installer created in the Luxrender folder and copied it over to my blender install.

Ahh, I just checked and Blender is showing the LuxBlend exporter to be version 1.4.

I tried downloading the latest dev version but that doesn't include pylux

Edit:l nevermind, I got it. I installed the LuxBlend version from the installer and then copied over the latest version from your download and let it overwrite all the files that had the same name. It seems to be working now.

Seems there is an old LuxBlend in the official download for 64 bit Windows no OpenCL
"Giggidy"
J the Amateur
 
Posts: 63
Joined: Sat Mar 05, 2011 6:59 pm

Re: LuxRender v1.5RC1 release

Postby B.Y.O.B. » Sun Jun 21, 2015 8:39 am

J the Amateur wrote:I tried downloading the latest dev version but that doesn't include pylux

That doesn't matter if you set the path to the main LuxRender folder in the addon settings, it will then load pylux/pyluxcore from there.
User avatar
B.Y.O.B.
Developer
 
Posts: 5049
Joined: Wed Nov 10, 2010 4:10 pm
Location: Germany

Re: LuxRender v1.5RC1 release

Postby SATtva » Sun Jun 21, 2015 9:33 am

Yeah, just don't forget to restart Blender after updating the path.
Linux builds packager
聞くのは一時の恥、聞かぬのは一生の恥
User avatar
SATtva
Developer
 
Posts: 7162
Joined: Tue Apr 07, 2009 12:19 pm
Location: from Siberia with love

Re: LuxRender v1.5RC1 release

Postby J the Amateur » Sun Jun 21, 2015 10:17 am

B.Y.O.B. wrote:
J the Amateur wrote:I tried downloading the latest dev version but that doesn't include pylux

That doesn't matter if you set the path to the main LuxRender folder in the addon settings, it will then load pylux/pyluxcore from there.


Guys, I swear I'm not trying to cause problems here but that didn't work.

I followed this process originally : I installed the 1.5RC1 package (Windows 64 bit, no OpenCL) from the download page. I then copied the bundled LuxBlend into my addons directory. Come to find out this version of LuxBlend is 1.4, not 1.5. So I delete that LuxBlend and download the latest dev version. I copy that over, enable it in Blender, verify it is pointing to the install folder, and restart Blender. I then re-enable the addon and am immediately greeted with errors about the Pylux module being missing, and none of the internal rendering modes are available. Material preview also doesn't work.

Here is what I see in the install folder on my hard drive:
Untitled.jpg


I don't see any sign of the Pylux or Pyluxcore modules.

As I stated a few post ago, the only way I could get the material preview and internal modes to work was by using the bundled LuxBlend and then copying the 1.5 dev build into the same folder, allowing it to overwrite the files.

From what I'm seeing in SATtva and B.Y.O.B.'s replies it looks like the 1.5RC1 installer needs to be revisited at as it's omitting files in some places and using obsolete versions in others.
"Giggidy"
J the Amateur
 
Posts: 63
Joined: Sat Mar 05, 2011 6:59 pm

Re: LuxRender v1.5RC1 release

Postby mjc » Sun Jun 21, 2015 10:40 am

J the Amateur wrote:From what I'm seeing in SATtva and B.Y.O.B.'s replies it looks like the 1.5RC1 installer needs to be revisited at as it's omitting files in some places and using obsolete versions in others.


Or simply not overwriting old versions...which could be a Windows/permissions problem.
mjc
 
Posts: 5
Joined: Sat Dec 29, 2012 1:42 pm

Re: LuxRender v1.5RC1 release

Postby B.Y.O.B. » Sun Jun 21, 2015 10:45 am

Sorry, I forgot one step: you have to copy all the .dll and .pyd files from the LuxBlend zip archive (from the downloaded build package) into the main LuxRender folder.

Btw. the packaging mechanism should be changed to do this instead of putting the files into the LuxBlend archive.
And you are certainly right about the outdated LuxBlend being wrong in the packaged build, that should be corrected.
User avatar
B.Y.O.B.
Developer
 
Posts: 5049
Joined: Wed Nov 10, 2010 4:10 pm
Location: Germany

Re: LuxRender v1.5RC1 release

Postby burnin » Sun Jun 21, 2015 12:37 pm

Great work, nice to see it going on well.
Though using LuxCore API (Experimental), Material Preview doesn't work:
NameError: name 'BlenderSceneConverter' is not defined

Classic API works as usual.

Removed all previous versions, cleaned registries, done clean install...
OS: win7, Blender2.75RC2
Is it still on to-do list or should it work already?

Thanks for all.
burnin
 
Posts: 223
Joined: Mon May 03, 2010 8:04 pm

PreviousNext

Return to News & Announcements

Who is online

Users browsing this forum: No registered users and 2 guests