LuxRender v1.5RC1 release

News & Announcements regarding releases, features, exporters and project coordination.

Moderators: Dade, coordinators

Re: LuxRender v1.5RC1 release

Postby acasta69 » Sat Jun 27, 2015 8:05 am

Thanks for the tip.
Regarding the path to LuxRender, it is actually set correctly:

userprefs.png

but the files do not get loaded unless they are in the LuxBlend folder...
Any idea about what could cause this?
Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v376.54
acasta69
 
Posts: 294
Joined: Fri Dec 20, 2013 3:18 am

Re: LuxRender v1.5RC1 release

Postby acasta69 » Sat Jun 27, 2015 2:12 pm

The problem is solved.
There was an existing old installation of LuxRender 1.3.1 on the system.
For some reason, PyLux and PyLuxCore libraries were searched in that location, no matter that the "Path to LuxRender" was set differently in the LuxBlend addon properties.
Once I uninstalled the old version, everything began to work properly, i.e. libraries loaded from the proper LuxRender folder, without need to have them also in LuxBlend folder.
Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v376.54
acasta69
 
Posts: 294
Joined: Fri Dec 20, 2013 3:18 am

Re: LuxRender v1.5RC1 release

Postby B.Y.O.B. » Sat Jun 27, 2015 2:28 pm

When you change that path, you have to save the UserPrefs and restart Blender to apply the changes. Maybe that was the problem (but that's just a guess).
User avatar
B.Y.O.B.
Developer
 
Posts: 5094
Joined: Wed Nov 10, 2010 4:10 pm
Location: Germany

Re: LuxRender v1.5RC1 release

Postby acasta69 » Sat Jun 27, 2015 4:09 pm

I don't know... I've tried many times, I'm pretty sure that I saved prefs and restarted...
Is there any possibility that the path where to search may be also set by some other means, for instance an environment variable?
Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v376.54
acasta69
 
Posts: 294
Joined: Fri Dec 20, 2013 3:18 am

Re: LuxRender v1.5RC1 release

Postby cisi » Mon Jun 29, 2015 6:45 am

Hi,

i think i hit a bug when using glossytransluscent material:
This ist the standard sampler renderer output:
MyLuxScene2.png


this the luxcore version: (notice the bright white line on the shadow edge):
MyLuxScene.png


the scene is extreme just to demonstrate it.
Its present also in complex textured "normal" scenes:
1.jpg

2.jpg
2.jpg (11.08 KiB) Viewed 1841 times




lxs file attached.
MyLuxScene.lxs
scenefile
(589.01 KiB) Downloaded 101 times



an other question:
are this kind of textures:
lux::ShinyMetal
lux::MultiMixTexture
lux::BandTexture
lux::LocalMapping3D

deprecated? they work in the original renderer but not in luxcore.
I use them a lot for procedural marble and wood. (and metals)

regards,
cisi
 
Posts: 53
Joined: Fri May 10, 2013 12:41 pm

Re: LuxRender v1.5RC1 release

Postby jeanphi » Mon Jun 29, 2015 8:47 am

cisi wrote:i think i hit a bug when using glossytransluscent material:

Thanks for the report, I'll look after it.

cisi wrote:are this kind of textures:
lux::ShinyMetal
lux::MultiMixTexture
lux::BandTexture
lux::LocalMapping3D

deprecated? they work in the original renderer but not in luxcore.

LuxCore doesn't yet support all classic Lux features (that will be when we release v2.0) but each new version currently brings us closer to that target.

Jeanphi
jeanphi
Developer
 
Posts: 7943
Joined: Mon Jan 14, 2008 7:21 am

Re: LuxRender v1.5RC1 release

Postby pciccone » Mon Jun 29, 2015 9:27 am

Jeanphi, is it possible to have a list of what is not yet supported?
User avatar
pciccone
Developer
 
Posts: 1579
Joined: Wed Jan 13, 2010 11:02 am
Location: South Carolina

Re: LuxRender v1.5RC1 release

Postby B.Y.O.B. » Mon Jun 29, 2015 10:51 am

cisi wrote:are this kind of textures:
lux::ShinyMetal
lux::MultiMixTexture
lux::BandTexture
lux::LocalMapping3D

deprecated? they work in the original renderer but not in luxcore.

You can recreate ShinyMetal by using a Mirror and adding GlossyCoating (use the Mirror as base material).
The band texture should be supported. Which exporter are you using?
User avatar
B.Y.O.B.
Developer
 
Posts: 5094
Joined: Wed Nov 10, 2010 4:10 pm
Location: Germany

Re: LuxRender v1.5RC1 release

Postby cisi » Mon Jun 29, 2015 1:58 pm

actually i use a free perl-export-script for poser im updating from time to time when new luxrender features come out.
For rendering i used the 1.5 RC1 Gui and it throws me that the 4 textures mentioned are not supported.
Thaks for the shinymetal tip.

regards,
cisi
 
Posts: 53
Joined: Fri May 10, 2013 12:41 pm

Re: LuxRender v1.5RC1 release

Postby jeanphi » Tue Jun 30, 2015 4:02 am

pciccone wrote:Jeanphi, is it possible to have a list of what is not yet supported?

There is this meta task in the bug tracker: http://www.luxrender.net/mantis/view.php?id=1445
But it is not fully up to date, it'd be good if all devs could have a look at it.

Jeanphi
jeanphi
Developer
 
Posts: 7943
Joined: Mon Jan 14, 2008 7:21 am

PreviousNext

Return to News & Announcements

Who is online

Users browsing this forum: No registered users and 2 guests