Fr FAQ - LuxRender Wiki
Luxrender GPL Physically Based Renderer

Fr FAQ

Personal tools

From LuxRender Wiki

Jump to: navigation, search

Questions fréquemment posées au sujet de LuxRender

Contents



Comprendre LuxRender

Où est enregistrée l'image produite?

LuxRender enregistrera périodiquement l'image produite dans le même dossier que le fichier .lxs de la scène. La temporisation entre chaque enregistrement peut être configuré dans votre exporteur. Vous pouvez enregistrer le rendu manuellement en sélectionnant File > Export to Image. Vous pouvez aussi cliquer le bouton de Copie d'écran dans l'interface pour copier la "mémoire-tampon" du rendu dans le presse-papier.

Quand est terminé mon rendu? Faut-il arrêter LuxRender?

LuxRender est un moteur de rendu spectrale progressif. Par défaut, il va continuer à améliorer votre image jusqu'à ce que vous soyez satisfait et l'arrêtiez. Si vous voulez que ça cesse après un certain nombre d'échantillons par pixel, par exemple lors du rendu d'une animation, utilisez les paramètres de "Arrêt SPP" ou de "Temp d'arrêt" (Voir le manuel de votre exporteur pour plus d'informations sur la configuration des paramètres de rendu).

Cela vaut pour les modes de rendu biaisées ainsi!

Pourquoi LuxRender est plus lent que d'autres moteurs de rendu?

C'est largement dû à la nature des algorithmes impliqués. LuxRender est conçu essentiellement comme un simulateur physique. Il génère des images entière au moyen de "lancer de rayons", et effectue ces calculs en utilisant le spectre réel des rayons lumineux, plutôt qu'une couleur RVB. Par défaut, LuxRender utilisera également une méthode de rendu "impartiale" (la transport de lumière "Métropolis"). Les méthodes "impartiales" sont par nature plus lente que les méthodes approximatives, car elles doivent faire le rendu en tenant compte indistinctement de tout dans la scène. LuxRender possède aussi des modes de rendu "approximatifs" qui seront significativement plus rapide.

Le côté positif de toute cette lenteur est que LuxRender produit des images extrêmement réalistes, presque sans s'embêter avec des paramètres. Le rendu 3D est toujours un compromis, il n'y a pas de méthodes de rendu parfaits. S'il y en avait, tout le monde l'utiliserait, et nous n'aurions pas d'innombrables moteurs de rendu dans le monde.

Quels modes de LuxRender sont très utilisés et lesquels sont totalement PBR?

En réalité, ça dépend un peu des paramètres utilisés pour des cas précis, mais en général:

  • Approximatifs: "Lumière directe", "Illumination Globale Instantanée", "Ex-carte de Photon", "Chemin Distribué".
  • Impartiaux & PBR: "Chemin" & "Bi-Directionnel".

Pourquoi LuxRender laisse des taches lumineuses sur mon image? Les autres moteurs de rendu ne font pas ça!

Par défaut, LuxRender utilise un échantillonneur "Métropolis-Hastings". Il est, en un sens, attirés par des objets brillants. En conséquence, il a l'habitude de laisser occasionnelle des touffes de "lucioles" ou "pixels lumineux" dans l'image. Ceux-ci disparaissent au fil du temps lorsque l'image réunit plus d'échantillons. L'échantillonneur "Métropolis" est extrêmement utile pour trouver ces chemins de lumière difficiles, comme les caustiques.

Si vous trouvez indésirable ce comportement, vous pouvez utiliser l'échantillonneur "Faible écart" à la place. Cet échantillonneur distribue des échantillons sur un modèle quasi-aléatoire à travers l'image, ce qui devrait maintenir le bruit uniforme même s'il s'affaiblit. Cela peut être utile pour des images d'animation, où la cohérence du bruit est plus importante que la clarté globale.

Que veut dire la statistique "eff", et pourquoi est-elle supérieur à 100%?

Le paramètre "eff" concerne l'efficacité, et mesure essentiellement s'il est facile pour LuxRender de "trouver la lumière". Actuellement il mesure combien de contributions de lumière chaque échantillon possède en moyenne. En fonction des algorithmes de rendu que LuxRender utilise, il est très fréquent de voir un taux d'efficacité de plus de 100%. Par exemple, alors que le lancer de chemin "Bi-Directionnel" passe plus de temps par échantillon (le nombre des échantillons / seconde est inférieur), il obtient généralement un taux d'efficacité beaucoup plus élevé que le mode "Chemin" standard. En d'autres termes, vous obtiendrez plus d'efficacité avec le mode "Bi-Directionnel".

En fait, votre efficacité devrait toujours être plus de 100%, sauf avec l'intégrateur "Ex-Carte de Photon" (qui est un peu différent des autres pour la mesure de l'efficacité). Des efficacité égales ou inférieures à 100% avec des algorithmes de lancer de chemin (les modes "Chemin" ou "Bi-Directionnel") indique un échantillonneur mal configuré ou une scène très difficile. Lisez Ma scène possède une très faible "efficacité"! pour plus infos.



Caractéristiques

Est ce que LuxRender supporte l'accélération GPU?

LuxRender suporte l'accélération GPU pour certains modes de rendu. Plus précisément, l'intégrateur "Chemin" possède un "jumeau caché" qui utilise l'accélération GPU. Pour plus d'informations, lisez la documentation sur l’accélération GPU

Est ce que LuxRender supporte les caustiques?

Absolument! les caustiques sont un phénomène naturel créé par les changements de direction produit par la lumière en se réfléchant ou se réfractant, donc aucun effort n'est nécessaire pour que les modes "impartiaux" les supportent.
Plusieurs modes "approximatifs" de LuxRender peuvent aussi supporter les caustiques. Dans les faits, ils seront par nature moins spécialement dotés pour les traiter.

Est ce que LuxRender supporte n'importe quelles "passes"?

Depuis la version 1.4, LuxRender supporte les passes grâce à la nouvel API LuxCore: page du Wiki
Pour les anciennes versions ou si vous n'utilisez LuxCore, l'ancienne réponse à cette question est toujours valable:

Pas vraiment! Dans le sens traditionnel, els passes impliquent d'enregistrer les étapes séparées du calcul de rendu dans des fichiers séparés. Comme la passe "Ombres seulement" par exemple. LuxRender ne peut pas le faire, car il ne peut pas utiliser de multiples étapes pour construire l'image finale en premier lieu! Il tire tout simplement les rayons dans la scène jusqu'à ce qu'on dise d'arrêter. Par exemple, il n'y a pas de passe d'ombre, les ombres sont tout simplement des endroits où moins de rayons sont perdus, donc ils sont devenus plus sombres.

LuxRender n'avait pas de groupes d'éclairages. Il garde la trace des lumières qui ont contribuées à l'image finale, donc il est possible de désactiver sélectivement certaines lumières. Cela permet de produire des images supplémentaires contenant uniquement un sous-ensemble de lumières, comme les phares de la voiture dans une scène de "nuit" d'une ville.

Est ce que le SSS (la diffusion de sous-surface) est supporté dans LuxRender?

Oui, c'est disponible via le support de type "homogène". Le type "Homogène" offre une simulation physiquement correcte des phénomènes optiques derrière la diffusion de sous-surface, plutôt que les faux effets SSS utilisés dans de nombreux moteurs de rendu approximatifs. Un peu d'histoire sur la diffusion de sous-surface:

La diffusion de sous-surface est un processus de transmission de la lumière à travers des matériaux "non-homogènes", principalement constitué de faible densité, mais il y a des exceptions comme les perles ou l'ambre. (Remarque: Le type de milieu "homogène" est nommé ainsi pour la distribution uniforme de ses "particules". Ainsi strictement parlant, il simule un milieu non homogène uniformément répartie) Les photons de lumière ne se transmettent pas en ligne droite au travers de ces milieux comme ils devraient le faire avec le verre, et ils ne reflètent pas instantanément sur la surface comme un matériau diffus. Au contraire, en raison de l'interaction avec des inclusions microscopiques parcourant tout le milieu, les photons peuvent perdre considérablement une partie de leur énergie et suivent des changements de trajectoire.

Le processus de diffusion de sous-surface a deux composantes et des matériaux exposés différemment dans des proportions variables:

  • 1) La transmission de subsurface: avec laquelle un photon de lumière va se transmettre en traversant le milieu, mais l'axe de sortie étant souvent très différent de l'axe d'entrée.
  • 2) La réflexion de sous-surface: selon laquelle le photon passera par une série d'interactions souterraines et ensuite quittera le milieu avec la même direction générale qu'il est entré, mais loin de l'impact où il est entré.

Notez qu'en raison de la nature du système de volume de LuxRender, la diffusion SSS ne peut pas être utilisée avec des maillages 3D "plan", car LuxRender va penser que l'espace entre les faces du plans est en fait l'espace intérieur de lui-même. Il faut épaissir le maillage 3D pour que LuxRender ait un volume réel pour calculer la dispersion SSS.

Est-ce que LuxRender exporte les rendus au format image à haute plage dynamique (HDR)?

Mieux que ça. Quand la plupart des moteurs de rendu parlent de "rendu HDR", ils font référence aux valeurs RVB en 16 bits ou 32 bits pour calculer l'image, par opposition à la couleur 8bit de nos moniteurs et des couleurs que les imprimantes utilisent. LuxRender est entièrement spectrale, ce qui signifie qu'il n'utilise pas les valeurs RVB en lançant les rayons. Il utilise le spectre réel et la puissance du rayon. Pour cette raison, la plage dynamique de la luminosité et la couleur calculée ne sont pas limitée par la précision d'une valeur RVB. Après le spectre final du rayon trouvé, il est converti en [couleur] sur la "pellicule XYZ". les valeurs RVB sont utilisées seulement pour l'exportation de l'image terminée.

Si vous préférez suivre un flux de production dans le style d'un labo photographique HDR pour terminer vos rendus, LuxRender convertira la "pellicule XYZ" en RVB 16 ou 32 bits et enregistrera le résultat dans un fichier OpenEXR. Ce fichier sera enregistré sans aucun traitement supplémentaire, vous laissant un fichier prêt à être transformé ensuite dans un post-traitement de "Tone-mapping". Aucun rendu multiple avec différentes expositions ou différentes fusion ne seront nécessaire.

Est ce que LuxRender supporte les "lumières noires"?

Les "lumières noires" sont pris en charge, il y a même un préréglage pour la texture "lampspectrum" pour un. Toutefois, lorsque la plupart des utilisateurs se posent cette question, ils sont curieux de savoir si l'emploi d'une "lumière noire" dans LuxRender donnera automatiquement des effets rougeoyants. Donc, la question qu'ils se demandent vraiment (même si ils ne le savent pas!) est: "Est ce que LuxRender prend en charge la "fluorescence"? La réponse est malheureusement non! LuxRender ne sait pas encore que la lumière qui frappe un matériau peut affecter les propriétés d'émission de ce matériau, donc la fluorescence est actuellement absente. Cette fonction n'a toujours été ajoutée, et est assez loin sur la liste des priorités, car elle n'est pas très utile en dehors des scènes occasionnelles impliquant des "lumières noires".

Est ce que LuxRender supporte les lumières "laser"?

Oui! LuxRender possède un type de lumière "laser"! Lisez ce sujet du forum pour plus d'infos.



Comment faire pour ....?

Comment faire pour continuer une rendu plus tard?

La meilleure façon de poursuivre un rendu plus tard, se présente comme suit:

  • Arrêter le rendu dans LuxRender et utilisez "Fichier > Save FLM..." pour sauvegarder l'état actuel du rendu dans un fichier .flm.
  • LuxRender peut maintenant être fermé.
  • Plus tard, quand vous voudrez reprendre le rendu, vous n'aurez qu'à ouvrir LuxRender et utiliser "Fichier > Reprendre FLM", ouvrir le fichier .lxs de la scène en question, ou tout simplement double-cliquer sur le fichier .lxs si votre système d'exploitation a associé LuxRender à ce type de fichier. LuxRender utilisera automatiquement le fichier .flm que vous avez enregistré précédemment et reprendra là où vous vous étiez arrêté.

NOTE 1: Le bouton "Load FLM" vous permet d'ouvrir un fichier .flm afin d'effectuer le post-traitement, mais il ne permet pas d'accomplir de rendu.

NOTE 2: Tout ce qui précède suppose que vous n'avez pas sélectionné le bouton "Restart / Erase" de votre exporteur. Si vous l'avez fait, alors la reprise du rendu recommencera depuis le début. Pour changer ça, vous devez modifier manuellement le fichier .lxs de votre scène en l'ouvrant dans un simple texteur. Voir les détails pour ce faire dans la "note" au bas de cette page.

Je veux utiliser LuxRender pour une animation. Comment dois-je faire?

Strictement parlant, vous pouvez faire le rendu d'une animation avec LuxRender indépendamment des paramètres utilisés. Puisque cela peut conduire à de longues et imprévisibles temps de rendu (bien au-delà de ce qui est faisable quand vous avez quelques centaines d'images (ou milliers) à faire), il y a quelques astuces que vous pouvez utiliser pour réduire votre temps de rendu à quelque chose de raisonnable.

  • Premièrement: vous devez éviter l'échantillonneur "Métropolis". Bien qu'il est utile pour les rendus fixes, il ne distribue pas les échantillons de manière uniforme sur l'image. Il a tendance à produire des amoncellements de "lucioles" problématiques lors de rendus de nombreuses images en succession rapide. Les "lucioles" aléatoires de "Métropolis" peuvent être très perceptibles, car ce sont des points d'une trame qui ne sont pas uniformes. L'échantillonneur "Faible écart" devrait vous donner à avoir des résultats beaucoup plus cohérents. Quand une seule image est affichée en une fraction de seconde, la cohérence du bruit restant est plus important que d'essayer de se débarrasser de la totalité de celui-ci.
  • Deuxièmement: vous devez utiliser le tone-mapping "Linéaire" pour toutes les images. Il utilise une exposition fixe, tandis que "Reinhard", "Auto-linéaire", et le contraste des tone-mappings tentent tous de s'adapter à la luminosité de l'image. L'utilisation d'un tone-mapping autre que "Linéaire" se traduira par un scintillement entre trames. C'est la même raison pour de ne jamais utiliser l'auto-exposition sur une caméra vidéo lors d'un tournage d'une scène pour un film, sauf que dans ce cas CG, l'auto-exposition est recalculée à partir de zéro pour chaque image.
  • Vous voudrez peut-être utiliser l'intégrateur "Ex-Carte de photon". S'il peut laisser des artefacts sur certaines zones, vous pourrez les contenir, et ces réglages seront souvent les mêmes pour toutes les images d'un coup. On effacera le bruit beaucoup plus rapidement qu'avec les intégrateurs "Bi-Directionnel" ou "Chemin".
  • LuxRender doit s'arrêter en quelque sorte après chaque image. Vous pouvez faire cela avec les valeurs de "Arrêt durée" ou "Arrêt SPP". Le paramètre "Arrêt SPP" arrête LuxRender quand il atteint une qualité spécifiée pour les échantillons par pixel, "Arrêt durée" arrête LuxRender après une durée spécifié.
  • Enfin, vous pouvez utiliser la fonction de file d'attente de l'interface de LuxRender pour charger toutes vos images pour un traitement par lots de vos rendus. Si vous utilisez le rendu en réseau, LuxRender enverra automatiquement chaque image à tous les nœuds de rendu. Quand une image est terminée, LuxRender va rassembler tous les échantillons provenant du réseau avant de les enregistrer sur le disque et de passer, pour assurer tout le travail qui a été fait est sauvé.

Pour plus d'informations, lisez la page Rendu d'une animation.

Comment ajouter un fond? (contournement du problème)

  • Utilisez une texture d'éclairage environnemental (hdr).
  • Activez un canal alpha à l'image produite, et ajoutez une image de fond en post-production. Cette méthode a l’inconvénient évident que ce fond ne sera pas visible dans les réflexions.

J'ai une scène avec des sources de lumière et des géométries complexes masquées derrière de nombreux obstacles. Quelle est la meilleure façon d'en faire le rendu?

Changez votre échantillonneur pour "Métropolis", et définissez une valeur importante à la "probabilité de mutation" sur ~0,1 et réglez les "rejets consécutifs max." sur environ [150~250]. Vous devez également augmenter la "Profondeur max." pour votre intégrateur de surface. En outre, "Ex-Carte de Photon" et nouveaux intégrateurs "GPSR" peuvent plus facilement faire face à des sources de lumière complexes, bien que vous devriez vous rappeler que seul le mode "GPSR" est impartiale.

Notez que comme pour tout moteur de rendu, des sources lumineuses "occultées / indirectes" devraient être évitées si possible!

Je pense à l'achat d'un nouvel ordinateur pour les rendus avec LuxRender. Quelles caractéristiques sont les plus importantes à cet effet?

  • Le nombre de cœurs du processeur, la vitesse d'horloge CPU et la taille du cache L2/L3 du processeur, prenez le maximum de ceux-ci pour votre budget.
  • Prenez en compte que le rendu d'images en haute résolution avec LuxRender nécessite de très grandes quantités de mémoire physique (non-échangées); si vous voulez produire de tels rendus, équipez votre machine avec au moins 4-8Gb de RAM.
  • Si vous prévoyez d'utiliser le mode "Hybride" de LuxRender, une carte graphique OpenCL puissante sera également bénéfique. Plus de fonctionnalités dans le mode "Hybride" sont prévues pour les versions futures, mais toutefois il est utile de garder une mise à jour ouverte pour des cartes graphiques plus rapides.



Quelque chose ne va pas bien, je fais quoi?

Ma scène a traitée un rendu pendant des heures, mais il est encore très rempli de bruit!

Tout d'abord, noter que même sur des machines puissantes, certaines scènes pouvent prendre plus de 12 heures pour obtenir des résultats satisfaisants (et beaucoup plus avec des résolutions élevées). Cependant, on peut essayer plusieurs choses pour obtenir plus rapidement des résultats satisfaisants:

  • Pour les scènes d'intérieurs, utiliser les portails lorsque vous avez des fenêtres ou des ouvertures où la lumière peut entrer.
  • Si votre scène contient beaucoup de verre, mais que vous ne voulez pas d'effet de réfraction du verre (fenêtres ou similaire), activez l'option "Architecture" dans le matériau "Verre".
  • les scènes contenant des murs très vifs (blanc) peuvent conduire à une image bruitée. Essayez d'en faire le rendu légèrement plus foncée. Vous pouvez essayer d'ajuster les paramètres de tone-mapping pour compenser.
  • Un matériau brillant est beaucoup plus lent qu'un matériau mate, et produit plus de bruit. Plus il est brillant, plus il produira de bruit. Réfléchissez à deux fois avant de l'utiliser ou de démarrer la création d'un matériau brillant. Le matériau "Mate" est préférable pour des choses comme les cloisons sèches ou le béton.
  • Essayez d'utiliser Le lancer de chemin "Bi-Directionnel" avec l'échantillonneur "Métropolis", même si votre rendu est une scène d'extérieur. Le mode "Chemin" simple est souvent moins efficace que "Bi-Directionnel", même pour les scènes d'extérieurs.
  • En dernier recours, une fois que vous avez une image très lisse échantillonné et qu'il reste encore un peu de grain, vous pouvez essayer certains filtre de débruitage dans un logiciel de retouche d'image comme Adobe Photoshop ou GIMP. LuxRender lui-même est déjà livré avec 2 options dans l'onglet de réduction du bruit en niveaux de gris: "Greyscale Restoration" & "Chiu".

J'ai rendu ma scène dans LuxRender, mais elle ne parait toujours pas réaliste

La plupart du temps, c'est dû à un éclairage irréaliste lorsque l'utilisateur travaille avec un moteur de rendu approximatif. Généralement avec LuxRender, les lampes ponctuelles et les spots doivent être évitées car ils ne sont pas vraiment réaliste. Pour obtenir une lumière directionnelle, vous devez plutôt utiliser soit une surface de lumière avec un objet réfléchissant autour de lui, soit un profil IES. Des paramètres matériels irréalistes peuvent aussi causer des problèmes, vous devriez éviter des valeurs de couleur extrêmes comme 0.0 ou 1.0 (c.a.d. 255).

Les images de LuxRender semblent trop ternes ou plates. Que puis-je faire

La réponse à la lumière dans LuxRender est par défaut "linéaire" dans la mesure où la couleur est concernée, et avec une luminosité comme si vous sélectionniez le tone-mapping "Linéaire". La plupart des appareils photo numériques ne se comportent pas de cette façon, ils ne peuvent produire d'images ternes et ennuyeuses. Vous pouvez utiliser la fonction "Réponse du Film" pour imiter le comportement des appareils photo pour obtenir une palette riche de couleurs plus variées. Un certain nombre de profils photo sont livrés avec LuxRender. Vous pouvez également essayer d'ajuster le contraste ou la saturation en utilisant un éditeur d'images comme GIMP ou Adobe Photoshop.

Je rencontre un usage intense de la mémoire lorsque je fais le rendu d'une scène avec LuxRender. Que puis-je faire?

LuxRender est très gourmand en ressources. Première suggestion: Installez autant de RAM que possible sur votre ordinateur. Les systèmes 32 bits peuvent utiliser jusqu'à 3-4Go, tandis que les systèmes 64 bits utilise 8Go. Lancez LuxRender sur les systèmes 32 bits avec moins de 4 Go de mémoire physique n'est pas recommandé pour une utilisation en production. Quelques conseils pour diminuer l'utilisation de la mémoire:

  • Basse résolution de l'image de rendu.
  • Désactivez les groupes de lumières si votre exporteur dispose d'une option pour ça.
  • Si vous faites un rendu "final", utilisez luxConsole car il utilise beaucoup moins de mémoire pour les grandes scènes (lisez la page LuxConsole pour les instructions).
  • Diminuez les niveaux de subdivision que vous utilisez sur votre géométrie 3D. Davantage de polygones augmentent l'utilisation de la RAM. Comme un "lanceur de rayon" pure, LuxRender doit charger toute la géométrie 3D dans la RAM et la maintenir pendant l'intégralité du rendu, donc chaque polygone de moins peut économiser de la mémoire.

J'ai suivi vos instructions et j'ai réglé la luminosité des matériaux sans dépasser [0,8~0,9]. Mais maintenant mes objets blancs ne paraissent plus blancs, ils sont devenus gris. Que puis-je faire?

Notre recommandation est de ne pas avoir la valeur de luminosité de toutes les couleurs, réparties entre [0,8~0,9]. C'est parce que ça crée un certain nombre de problèmes pour le moteur de rendu et vos images. Parmi eux, il y a beaucoup de taches de couleurs supplémentaires ou "lucioles" dans votre image et beaucoup de temps supplémentaire pour dé-bruiter votre image alors que le rendu est terminé. Si vos blancs ne sont pas blanc, vous pouvez faire soit:

  • Réglez les paramètres de "tone-mapping" avant le rendu.
  • Ajustez les paramètres de "tone mapping" pendant le rendu dans l'interface graphique de LuxRender dans l'onglet Image.
    Si l'algorithme de "tone-mapping" Reinhard est utilisé, vous pouvez réduire le paramètre Brûlure pour augmenter la luminosité, mais essayez de ne pas la sur-exposer.

Ma scène possède une très faible "efficacité"!

Si votre scène évolue vers une faible efficacité, cela signifie que LuxRender a du mal à trouver la lumière. Vous pouvez essayer d'améliorer la situation:

  • Essayez d'utiliser l'échantillonneur "Métropolis" et l'intégrateur de chemin "Bi-Directionnel", ce qui devrait accroître l'efficacité. Si vous utilisez déjà l'échantillonneur "Métropolis", vous pouvez essayer de réduire la probabilité de "Grande mutation". Méfiez-vous que l'abaissement ne soit trop important, LuxRender peut se "coincer" sur une lumière, et votre scène sera bruyant malgré une grande efficacité.
  • Pour les scènes d'intérieurs, utiliser les portails pour les fenêtres ou les ouvertures par où la lumière peut entrer.
  • Si votre scène contient beaucoup de verre (fenêtres ou similaires) où que vous ne vouliez pas de l'effet de la réfraction du verre, activez l'option "Architecture" dans le matériau "Verre".

La modification de la "puissance" de la lumière ne produit pas de résultat!

LuxRender utilise par défaut l'opérateur de tone-mapping "Reinhard". Ce mode de tone-mapping réglera la luminosité de la scène comme la plupart des appareils automatiques. Si vous ajoutez d'autres sources de lumière, toute différence d'intensité entre les lumières sera cependant apparent.

Sinon, vous pouvez utiliser le mode de tone-mapping "Linéaire", qui n'est pas dynamique.

Je reçois "Illegal instruction" pendant le démarrage de LuxRender!

Assurez-vous que vous avez téléchargé une version qui est compatible avec votre CPU. En cas de doute, essayez la version SSE (pas la version SSE2!).

Je vois des coups de brosses "blanc&noir" autour de mes lumières!

Si vous utilisez le filtre "Mitchell" (normalement recommandé), assurez-vous que l'option Super échantillon" est activée. Si cela ne résout pas le problème, vous pouvez utiliser le filtre "gaussien" à la place, bien que ça donnera une image un peu plus douce qu'avec "Mitchell".

J'ai ajouté des "portails" à une scène d'intérieur, mais la vitesse de rendu en Ks/s a ralenti énormément. Est-ce bon?

C'est normal. Ne pensez pas à cette valeur comme à une vitesse de rendu absolue parce que les différents échantillons apportent différentes contributions à la convergence de l'image. Observez plutôt la valeur "Eff" (efficacité) dans la barre d'état de LuxRender. Elle montre la contribution moyenne des échantillons calculés. Oui donc! En utilisant des portails, on ralentit le calcul de chaque échantillon de façon significative (les portails impliquent des mathématiques très compliqués), mais l'efficacité de chacun de ces échantillons peuvent facilement dépasser 1000%. Pour voir comment les choses net les, jetez un œil au taux de cotisation Kc/s (kilo-contributions par seconde). Il est calculé en combinant l'efficacité et la fréquence d'échantillonnage. Il devrait être au moins plus élevé avec des portails, probablement beaucoup plus élevé. Dans l'ensemble, il vaut mieux compter avec, essayez le rendu de deux images (une avec et l'autre sans portails) pour la même quantité de temps, et ensuite comparez visuellement si vous avez moins de bruit.



La licence GPL

LuxRender est un logiciel sous licence GPL. Qu'est-ce que ça signifie pour moi et mon entreprise?

Cela signifie que vous pouvez utiliser LuxRender en absolument pour tout ce que vous voulez, sur toutes les machines que vous possédez. Les projets personnels d'art, de travaux d'illustration du commerce, la visualisation des produits commerciaux. Si vous voulez l'utiliser pour rendre des éléments pour une superproduction hollywoodienne, nous serions honorés.

La licence GPL ne place pas de restrictions sur votre propre utilisation du programme. En fait, vous êtes même pas tenu d'accepter la licence GPL afin d'exécuter simplement LuxRender, seulement pour le distribuer à d'autres. (la distribution de LuxRender ou de toute autre application GPL implique l'acceptation de la licence) Vous pouvez installer des copies sur tous les ordinateurs de votre maison ou votre entreprise si vous voulez. Et considérant que LuxRender est multi-plateforme et construire des files d'attente et des rendu en réseaux, cela pourrait se révéler très utile.

La licence GPL est affectée lorsque vous avez l'intention de distribuer Luxrender ou vos modifications de lui. Dans ce cas, vous êtes tenu de fournir un lien vers le code source et la copie de la licence avec le fichier executable. La meilleure façon de s'en conformer est en donnant le fichier de l'archive de votre téléchargement, ou d'envoyer chacun vers la page de téléchargement LuxRender.

Pour plus d'informations, lisez la FAQ de la licence GPL de la Free Software Foundation à http://www.gnu.org/licenses/gpl-faq.html .

LuxRender étant un logiciel sous licence GPL, est ce qu'il nécessite le recours à une licence Copyleft sur les images que je produis avec lui?

Non!

Toutes les images et les fichiers de films produits par LuxRender sont considérées comme une "production du programme" au sens de la licence GPL. La licence GPL ne modifie pas les droits d'auteur de ces rendus en aucune façon. Si la scène est votre œuvre originale, vous restez le seul détenteur des notions de droits d'auteur.

La Fondation Blender a mis en place un guide utile sur la façon dont l'usage d'un logiciel sous licence GPL affecte les droits d'auteur quand il est utilisé dans un pipeline 3D. http://www.blender.org/education-help/faq/gpl-for-artists/

Si moi ou ma société modifie LuxRender pour notre propre flux de production, sommes-nous tenus de confier ces modifications au projet Luxrender?

Si la version modifiée de LuxRender ne quitte pas dans votre studio, le code source ne doit pas le quitter non plus.

Si vous choisissez de distribuer votre version modifiée de LuxRender, la licence GPL requière que vous produisiez une licence GPL pour votre modification et que vous fournissiez le code source en accompagnement pour ceux qui souhaitent l'avoir. Il ne nécessite pas de créer un patch avec vos modifications et en le soumettant au projet LuxRender, bien qu'il serait apprécié par de nombreuses personnes si vous le voulez. Vous êtes seulement tenus de publier le code source utilisé pour construire l’exécutable que vous distribuez.

Si vous n'êtes pas sûr de vos obligations de licence, vous devriez consulter un avocat.

Encore une fois, pour plus d'informations, lisez le FAQ de la Free Software Foundation sur la licence GPL à http://www.gnu.org/licenses/gpl-faq.html



Informations de second plan

Pourquoi ENCORE un autre moteur de rendu non-approximatif?

Des produits commerciaux et gratuits existent déjà, mais il n'existe pas de logiciel de moteur de rendu impartiaux, libre & orienté vers la production (note: "logiciels freeware" et "logiciels gratuit" ne signifie pas la même chose).

Choisir la voie du logiciel "gratuit" offre à notre avis plusieurs avantages:

  • Nous espérons que centraliser les contributions avec un modèle de développement open-source: tout le monde peut rejoindre le projet et ajouter des améliorations, trouver des bogues, porter le projet sur une plate-forme non prise en charge ou contribuer au développement des exportateurs et des tests. Cela pourrait être beaucoup plus rapide qu'un "one-man-band". Si un grand nombre de développeurs de moteur de rendu open source unissent leurs forces, il pourrait y avoir un tas de moteurs de rendu gratuits avec des fonctionnalités professionnelles, de convivialité et d'aides (exporteurs, préréglages, forum) très prochainement qui pourrait rivaliser avec les commerciaux. Dans l'état actuel des choses, il y a beaucoup de source de petits moteurs de rendu "freeware" et ouvert qui sont utilisés par des petits groupes d'amateurs, mais ne trouvent pas d'utilisations répandues dans le monde de la conception mécanique 3D.
  • LuxRender ne peut pas disparaître: Les développeurs "freeware" pourraient se lasser et arrêter le développement. Les programmes commerciaux peuvent être rachetés par d'autres sociétés ne poursuivant pas les objectifs économiques ou tombant en faillite, l'arrêt de l'entretien ou même de mise de retraite du logiciel. Il y a de nombreux exemples de telles situations. Avec LuxRender, le code GPL reste toujours, même si tous les développeurs originaux "quittent le bateau", les chances sont élevées que quand l'application est utilisée et nécessaire, il y ait quelqu'un pour prendre soin du code.
  • Toute personne intéressée peut l'utiliser sans frais, sans aucune restriction, ce qui est actuellement et dans les versions futures. Les moteurs de rendus gratuits sont souvent utilisés par les utilisateurs de Blender. Peut-être en raison du moteur de rendu de Blender interne sans GI, parce qu'ils aiment les logiciels libres ou tout simplement pour expérimenter. Fournir un rendu GPL "impartial" permet une intégration étroite entre ces outils (nous espérons une intégration complète dans Blender) et la garantie que les utilisateurs auront toujours le choix d'un logiciel libre.

Quelle est la différence entre LuxRender, SmallLuxGPU, et LuxRays?

LuxRender est le programme principal réalisé par le projet collectif. C'est un moteur de rendu de production 3D de qualité. Les versions stables, la documentation, des exécutables pré-compilés à télécharger, et toutes les choses que vous attendez d'un programme que vous souhaitez utiliser pour le travail 3D au jour le jour.

SmallLuxGPU est une application de banc d'essais de développement pour LuxRender. Il a été initialement conçu comme une expérience pour le rendu pour l'accélération-GPU, et dans une certaine mesure, l'interface utilisateur est minimaliste. Beaucoup de gens ont apprécié sa rapide de temps de rendu et sa légèreté, et il est devenu un moteur de rendu autonome. Il reste une expérience, ce n'est pas une version stable en soi. Ses caractéristiques deviennent stables en étant incorporées dans LuxRender. Pour cette raison, il n'est pas toujours simple de trouver un executable à installer & utiliser. LuxRender standard doit être utilisé lorsque la fiabilité et la facilité d'installation sont nécessaires.

LuxRays n'est pas une application de rendu. C'est une bibliothèque utilisée pour accélérer les applications de lancer de rayons par l'emploi de connexions OpenCL. Initialement, il travaillait uniquement en utilisant le GPU pour le lancer de rayons dans une configuration hybride CPU / GPU, mais il a depuis été élargi pour le rendu GPU pur uniquement. Il est plus rapide que le rendu "Hybride", mais les fonctionnalités avancées sont beaucoup plus difficile à mettre en œuvre et limitent considérablement les ressources disponibles pour le moteur de rendu (comme la mémoire).

Pourquoi créer une nouvelle branche au projet PBRT?

  • L'application PBRT est une projet très solide, donc nous n'avons pas à réinventer la roue. Il possède une conception propre et extensible, une documentation exceptionnelle (le livre) et il est utilisé dans les milieux académiques, de sorte que beaucoup d'étudiants le connaissent.
  • Les objectifs des deux projets diffèrent néanmoins: L'application PBRT est une recherche académique et un outil pédagogique, LuxRender est orienté vers l'artiste et sa production, ce qui crée des différences dans beaucoup de domaines. L'optimisation de la vitesse de LuxRender, la suppression des fonctions inutiles et les pratiques d'ajouts (exporteurs, interface graphique, multi-tâche, formats des fichiers, le MLT, etc...) sont ses objectif principaux.
    Les choix d'évolution sont fait avec et pour l'utilisateur final et avec uniquement l'efficacité artistique à l'esprit.
  • Notre chemin a reçu la bénédiction et les encouragements des auteurs du projet PBRT.