Blender 2.7 luxblend issue - I can't apply addon

Please use this forum for general user support and related questions.

Moderators: Dade, coordinators

Forum rules
Please include your operating system type/version, LuxRender version and Exporter version used when submitting a support post.

Make sure you have read the Release forum thread for Release and RC (Release Candidates) builds as these threads contain information on known problems and workarounds: Test Builds Forum

Blender 2.7 luxblend issue - I can't apply addon

Postby Makarleen » Thu Mar 01, 2018 7:16 pm

Hello...
I have problem with luxblend. I cant apply luxblend addon. Blender shows this message: (attachment)

OS: Fedora 27 x86_64 GNOME 3.26.2
CPU AMD® Fx(tm)-4300 quad-core processor × 4
GPU GeForce GTX 460/PCIe/SSE2 (Nvidia Xorg)
Luxrender 1.6-26.fc27
Python 2.7.14 (default, Feb 17 2018, 10:42:17)
[GCC 7.3.1 20180130 (Red Hat 7.3.1-2)] on linux2

Code: Select all
Traceback (most recent call last):
  File "<frozen importlib._bootstrap>", line 1519, in _find_and_load_unlocked
AttributeError: 'module' object has no attribute '__path__'

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
  File "/home/Makarleen/.Manual_Installed_Programs/Fedora/Blender_2.70/2.70/scripts/modules/addon_utils.py", line 299, in enable
    mod = __import__(module_name)
  File "/home/Makarleen/.config/blender/2.70/scripts/addons/luxrender/__init__.py", line 161, in <module>
    from . import core
  File "/home/Makarleen/.config/blender/2.70/scripts/addons/luxrender/core/__init__.py", line 60, in <module>
    from ..properties import (
  File "/home/Makarleen/.config/blender/2.70/scripts/addons/luxrender/properties/node_inputs.py", line 42, in <module>
    from ..properties.node_texture import triple_variant_items
  File "/home/Makarleen/.config/blender/2.70/scripts/addons/luxrender/properties/node_texture.py", line 28, in <module>
    import bpy.utils.previews
ImportError: No module named 'bpy.utils.previews'; bpy.utils is not a package


Can you help me?
How to fix it?
Attachments
luxrenderissue.png
Makarleen
 
Posts: 1
Joined: Thu Mar 01, 2018 6:51 pm

Re: Blender 2.7 luxblend issue - I can't apply addon

Postby B.Y.O.B. » Fri Mar 02, 2018 5:20 am

Have you tried with a more recent Blender version? 2.7 is quite old.

By the way, unfortunately LuxBlend is no longer supported, we are writing a new addon, if you want to test it write a post here: viewtopic.php?f=12&t=13485
However the new addon requires the very latest Blender (2.79a release candidate).
User avatar
B.Y.O.B.
Developer
 
Posts: 5181
Joined: Wed Nov 10, 2010 4:10 pm
Location: Germany


Return to LuxRender User Support

Who is online

Users browsing this forum: No registered users and 0 guests