LuxCore: issues, problems, regressions

Discussion related to the implementation of new features & algorithms to the Core Engine.

Moderators: Dade, jromang, tomb, zcott, coordinators

Re: LuxCore: issues, problems, regressions

Postby Piita » Wed Oct 26, 2016 12:07 pm

Excellent! Thanks B.Y.O.B.
I didn't know volume precedence was this awesome. It's so much easier to set up compared to the old way. It was not really a bug then, just me setting it up wrong, so please ignore my previous posts.

Did a test with 3 volumes (glass, water, IOR 1.8 stick) using volume precedence. Also tested it in classic lux setting it up the old way just to see if the refractions were the same. Never mind the color differences.

glass of water volume precedence.rar
(92.2 KiB) Downloaded 29 times

3 volumes luxcore volume precedence.jpg
3 volumes luxcore volume precedence.jpg (9.78 KiB) Viewed 1045 times


3 volumes classic.jpg
3 volumes classic.jpg (8.12 KiB) Viewed 1045 times
User avatar
Piita
 
Posts: 601
Joined: Sat Aug 06, 2011 2:09 pm
Location: Finland

Re: LuxCore: issues, problems, regressions

Postby burnin » Wed Oct 26, 2016 1:15 pm

Good looking results Piita!
-----------------------------------
neo, kalel, Dade
Great to know! Thanks for all the info. :D
Any advice for a tool to observe real-time stats and limits on GPU is more than welcome.

Q:
Are tiles planned for Path or is it otherwise simple to set biased to be unbiased (with tiles), could just a preset be available?
Also i've noticed slight differences in clamping fireflies (different values apply)... or is it me :mrgreen:
burnin
 
Posts: 252
Joined: Mon May 03, 2010 8:04 pm

Re: LuxCore: issues, problems, regressions

Postby B.Y.O.B. » Wed Oct 26, 2016 1:52 pm

Piita wrote: It was not really a bug then, just me setting it up wrong, so please ignore my previous posts.

But it's also wrong im my scene... did I also make a mistake? I could not find one and thought it might be a bug in LuxCore.

And yeah, volume precedence really is pretty sweet. :)
User avatar
B.Y.O.B.
Developer
 
Posts: 5095
Joined: Wed Nov 10, 2010 4:10 pm
Location: Germany

Re: LuxCore: issues, problems, regressions

Postby kalel » Wed Oct 26, 2016 5:04 pm

burnin wrote:Good looking results Piita!
-----------------------------------
neo, kalel, Dade
Great to know! Thanks for all the info. :D
Any advice for a tool to observe real-time stats and limits on GPU is more than welcome.

Q:
Are tiles planned for Path or is it otherwise simple to set biased to be unbiased (with tiles), could just a preset be available?
Also i've noticed slight differences in clamping fireflies (different values apply)... or is it me :mrgreen:


Path and Biaspath (OpenCL versions) after the Microkernel for Biaspath was added (you have this in the build you're using) share most of the same code.

That means, you can now make Path biased if for e.g. you limit the individual path depths, for e.g. diffuse 10, glossy and specular 1.

The same way, if you keep all of the depths equal on BiasPath, it should work almost the same.

Some difference comes from the sampler, Dade mentioned that at the moment, Biaspath is using something like random, while with Path you have both Metropolis, Sobol, and optionally random (not selectable in luxblend, but yes in GUI of luxcore, or with custom command). Metropolis works different than Random, and Sobol does too, so results may be different on some scenes. Also, Metropolis and Sobol or Random can all give different fireflies, so maybe that is the cause of your different clamping values.

I use simply MSI Afterburner for GPU usage\temp\etc stats, but you can find many tools as well.
kalel
 
Posts: 258
Joined: Sun Jul 17, 2016 6:35 am

Re: LuxCore: issues, problems, regressions

Postby acasta69 » Thu Oct 27, 2016 5:18 am

burnin wrote:Any advice for a tool to observe real-time stats and limits on GPU is more than welcome.

Another such tool is GPU-Z:
https://www.techpowerup.com/gpuz/
Quite lightweight, no install needed.
Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v376.54
acasta69
 
Posts: 294
Joined: Fri Dec 20, 2013 3:18 am

Re: LuxCore: issues, problems, regressions

Postby burnin » Thu Oct 27, 2016 8:19 am

^^Ahhh... so it is, simple as that. Great! 8-)

^Yeah, was using GPU-Z, but got crashing it on me lately :cry: ... will check MSi Afterburn.
Thanks again
burnin
 
Posts: 252
Joined: Mon May 03, 2010 8:04 pm

Re: LuxCore: issues, problems, regressions

Postby Piita » Sun Nov 06, 2016 5:24 am

Luxcore bidir glossy translucent and a volume does not cooperate :) Matte translucent does the same.
Same material but luxcore path renders it correctly.
Luxcore bidir glossy translucent without a volume renders correctly.
Luxcore bidir glass and volume works fine as we saw a few posts earlier with the glass of water
Kalel's Oct 15 build.

candle.rar
(124.91 KiB) Downloaded 19 times


01 luxcore bidir volume glossytranslucent.jpg
luxcore bidir volume glossytranslucent

01 luxcore path volume glossytranslucent.jpg
luxcore path volume glossytranslucent. This render is correct. Same result as classic lux
User avatar
Piita
 
Posts: 601
Joined: Sat Aug 06, 2011 2:09 pm
Location: Finland

Re: LuxCore: issues, problems, regressions

Postby Piita » Fri Nov 11, 2016 8:04 am

Having some problems with glossy coating. Do I have it set up the wrong way?

glossy coating 01.blend
(608.21 KiB) Downloaded 16 times


glossy coating nodes.jpg

01 yellow sphere luxcore.jpg
luxcore

01 yellow sphere classic lux.jpg
classic lux
User avatar
Piita
 
Posts: 601
Joined: Sat Aug 06, 2011 2:09 pm
Location: Finland

Re: LuxCore: issues, problems, regressions

Postby jensverwiebe » Fri Nov 11, 2016 8:20 am

Testscene in luxrays looks as its working, so perhaps exporter issue, will take a look asap.

Edit: testscene was misleading 'cause it uses matte as basemat.
Luxcore does not work when coating a null_mat or when the basemat is fully transparent ( feeding opacity with float value 0.0 ).
No workaround found yet.
Workaround: mix in a minimal white matte to get a hitpoint:
screenshot-area-2016-11-11-172720.png



BTW: tell Dade, this is a bug imho, the transparent basematcase should be taken into acount.
Jens
User avatar
jensverwiebe
Developer
 
Posts: 3402
Joined: Wed Apr 02, 2008 4:34 pm

Re: LuxCore: issues, problems, regressions

Postby Piita » Fri Nov 11, 2016 10:48 am

OK, that works. Thanks, Jens.
User avatar
Piita
 
Posts: 601
Joined: Sat Aug 06, 2011 2:09 pm
Location: Finland

PreviousNext

Return to Architecture & Design

Who is online

Users browsing this forum: No registered users and 3 guests