LuxMark v3.1: LuxRender propaganda with OpenCL

Discussions related to GPU Acceleration in LuxRender

Moderators: Dade, jromang, tomb, coordinators

Re: LuxMark v3.1: LuxRender propaganda with OpenCL

Postby acasta69 » Mon Dec 21, 2015 4:55 pm

Thanks for all support and information Dade.
At the moment I've upgraded the CPU drivers to the AMD SDK 3.0.
Luxmark recognizes it as "OpenCL 2.0 AMD-APP (1800.8)".
However, when I choose the "Benchmark (OpenCL CPUs)", the program crashes during "Compiling kernels".
Also Luxcore does not work properly any more: for example Biased Path is not working, this is the console output:

console.jpg

For the moment I will probably revert to the 2.9.1 SDK CPU drivers, since they never gave problems aside from that Luxmark result...
Windows 10 64 bits, i7-4770 3.4 GHz, RAM 16 GB, GTX 970 4GB v382.05
acasta69
 
Posts: 298
Joined: Fri Dec 20, 2013 3:18 am

Re: LuxMark v3.1: LuxRender propaganda with OpenCL

Postby borandi » Tue Apr 12, 2016 1:01 am

Is there any way on windows to specify just the CPUs, just the GPUs, or all CPU+GPU, from the command line for automation?
The current --mode switch just selects which code path to use, doesn't actually adjust the hardware in use.
I'd also love the ability for it to automatically upload from the command line with a given un/pw
borandi
 
Posts: 2
Joined: Tue Apr 12, 2016 12:58 am

Re: LuxMark v3.1: LuxRender propaganda with OpenCL

Postby Dade » Tue Apr 12, 2016 4:15 am

borandi wrote:Is there any way on windows to specify just the CPUs, just the GPUs, or all CPU+GPU, from the command line for automation?
The current --mode switch just selects which code path to use, doesn't actually adjust the hardware in use.
I'd also love the ability for it to automatically upload from the command line with a given un/pw


Aren't you looking for " --mode=BENCHMARK_OCL_GPU", "--mode=BENCHMARK_OCL_CPU" or "--mode=BENCHMARK_OCL_CPUGPU" :?:

Code: Select all
david@i7-3930k:~/projects/luxrender-dev/luxmark$ ./bin/luxmark --help
Usage: ./bin/luxmark [options]
 --help (display this help and exit)
 --scene=LUXBALL_HDR|MICROPHONE|HOTEL (select the scene to use)
 --mode=BENCHMARK_OCL_GPU|BENCHMARK_OCL_CPUGPU|BENCHMARK_OCL_CPU|BENCHMARK_NATIVE|STRESSTEST_OCL_GPU|STRESSTEST_OCL_CPUGPU|STRESSTEST_OCL_CPU|DEMO_LUXVR|PAUSE (select the mode to use)
 --single-run (run the benchmark, print the result to the stdout and exit)
 --ext-info (print scene and image verification too with --single-run)
User avatar
Dade
Developer
 
Posts: 8388
Joined: Sat Apr 19, 2008 6:04 pm
Location: Italy

Re: LuxMark v3.1: LuxRender propaganda with OpenCL

Postby borandi » Tue Apr 12, 2016 8:34 am

Just tried again.
I think I got confused as the checkboxes on display when the software loads aren't updated to match what's being specified in cmdline :D.
My bad.

Still, anything to be done about uploading results from the cmdline?
borandi
 
Posts: 2
Joined: Tue Apr 12, 2016 12:58 am

Re: LuxMark v3.1: LuxRender propaganda with OpenCL

Postby Dade » Tue Apr 12, 2016 2:17 pm

borandi wrote:Still, anything to be done about uploading results from the cmdline?


Mmmm, nope, there isn't a way at the moment.
User avatar
Dade
Developer
 
Posts: 8388
Joined: Sat Apr 19, 2008 6:04 pm
Location: Italy

Previous

Return to GPU Acceleration

Who is online

Users browsing this forum: Baidu [Spider] and 1 guest