LuxRender 0.9-dev Windows build of 14-12-2011

Weekly builds for testing and use between releases.

Moderator: coordinators

Forum rules
Please read the information / sticky post for some basic information regarding these builds/support.

LuxRender 0.9-dev Windows build of 14-12-2011

Postby Lord Crc » Wed Dec 14, 2011 2:05 pm

Celebrating the release of Blender 2.61, I've made some fresh weeklies. I see that you can now use the "Install addon..." to upgrade your LuxBlend25 install, by selecting to Overwrite the existing install. Any feedback on this would be appreciated.

The main changes this time is that jeanphi has continued his light sampling code cleanup, and that guibou has added a direct light sampling mode to SPPM. I've done some minor bug fixing.

Other noteworthy changes is in the LuxBlend25 exporter. I've fixed the texture preview, and I've fixed the handling of output files. First of all /tmp/ will now be replaced with %temp%, and if the output directory isn't writable it will fall back to %temp%. This should help new users get going out of the box.

These builds contain LuxRender, LuxConsole, LuxMerger, LuxBlend25 and Pylux for Blender 2.6x, and LuxBlend for Blender 2.49.
The NoOpenCL builds does not require any OpenCL driver or capabilities, but also does not use the GPU for the "hybrid" renderer.

LuxRender_CVS_20111214_64bit_OpenCL.exe
LuxRender_CVS_20111214_64bit_NoOpenCL.exe
LuxRender_CVS_20111214_32bit_SSE2_OpenCL.exe
LuxRender_CVS_20111214_32bit_SSE2_NoOpenCL.exe
LuxRender_CVS_20111214_32bit_SSE1_NoOpenCL.exe

Built with Visual Studio 2008 SP1 + Windows 7 SDK on Win 7 64bit, using AMD APP SDK 2.5 (formerly ATI Stream SDK).

Changelog:
Code: Select all
50 minutes ago   Asbjørn Heid   Fixed negative time remaining in stats.
42 hours ago   Jean-Philippe Grimaldi   Finish the light sampling clean up and restore the sampling count.
2 days ago   Jean-Philippe Grimaldi   Extend light sampling interfaces to make it easier to use.
3 days ago   Asbjørn Heid   Unified FreeImage error reporting.
3 days ago   Asbjørn Heid   Fixed tabs in pngio.cpp
3 days ago   Asbjørn Heid   Added ability not depend directly on libpng via LUX_NO_LIBPNG flag, uses FreeImage instead.
7 days ago   Guillaume Bouchard   SPPM: direct lighting mode.


Hope you enjoy!
May contain traces of nuts.
User avatar
Lord Crc
Developer
 
Posts: 4931
Joined: Sat Nov 17, 2007 2:10 pm

Re: LuxRender 0.9-dev Windows build of 14-12-2011

Postby Lord Crc » Thu Dec 15, 2011 4:00 am

Added writeup of changes.
May contain traces of nuts.
User avatar
Lord Crc
Developer
 
Posts: 4931
Joined: Sat Nov 17, 2007 2:10 pm

Re: LuxRender 0.9-dev Windows build of 14-12-2011

Postby jeanphi » Thu Dec 15, 2011 4:15 am

Hi,

Actually my light sampling cleanup is not finished, just the core part of it. I now need to clean up the users and make use of the interfaces everywhere it makes sense.

Jeanphi
jeanphi
Developer
 
Posts: 7218
Joined: Mon Jan 14, 2008 7:21 am

Re: LuxRender 0.9-dev Windows build of 14-12-2011

Postby Lord Crc » Thu Dec 15, 2011 4:30 am

Ah, thats what I get for not reading the whole diff :D

Fixed.
May contain traces of nuts.
User avatar
Lord Crc
Developer
 
Posts: 4931
Joined: Sat Nov 17, 2007 2:10 pm

Re: LuxRender 0.9-dev Windows build of 14-12-2011

Postby bamba » Thu Dec 15, 2011 12:44 pm

should sppm and direct light work only with random sampler? or do i have a problem. blend 2.61

bamba
bamba
 
Posts: 12
Joined: Sun Sep 12, 2010 8:21 am

Re: LuxRender 0.9-dev Windows build of 14-12-2011

Postby J the Ninja » Thu Dec 15, 2011 1:30 pm

bamba wrote:should sppm and direct light work only with random sampler? or do i have a problem. blend 2.61

bamba


No, known issue. It SHOULD work, but any sampler other than random will crash if you enable direct light.
-Jason

Material DB Admin
User avatar
J the Ninja
Developer
 
Posts: 2457
Joined: Wed May 19, 2010 9:54 pm
Location: Portland, USA

Re: LuxRender 0.9-dev Windows build of 14-12-2011

Postby bamba » Fri Dec 16, 2011 5:13 am

Thank you

bamba
bamba
 
Posts: 12
Joined: Sun Sep 12, 2010 8:21 am

Re: LuxRender 0.9-dev Windows build of 14-12-2011

Postby syndaryl » Fri Dec 16, 2011 8:16 am

Install-Addon upgrade in Blender worked perfectly! :D
Roter Sand und weisse Tauben \ Laben sich an meinem Blut
Am Ende gibt es doch ein Ende \ Bin ich doch zu etwas gut
User avatar
syndaryl
 
Posts: 156
Joined: Sun Sep 05, 2010 11:28 pm

Re: LuxRender 0.9-dev Windows build of 14-12-2011

Postby HoloFan » Thu Dec 22, 2011 3:51 pm

Except for the presets theluxblend installation it worked perfectly for me as well.

But when I start OpenCL Bidir (the preset 'OpenCL MLT & Bidirectional') not only luxrender but the whole PC crashes. My System is a Sony Vaio SB notebook with a AMD HD 6630M and my driver version is 8.862.4.3-110926a-126759C-Sony.
This is the latest one you can get from Sony. The Notebook has a button which changes the Graphics-chip from the AMD to the integrated intel-graphics. When the AMD is running the Intel shows up in the device manager as well.
Maybe there is somehow the problem.
I'm using blender 2.61 stable and the latest luxblend from src.luxrender.net.
HybridPath is working perfectly....

I have some limited experience with programming and I even did once some experiments with the Stream SDK. So if someone guides me I could perhaps do some things on my own. But I will need good guidance. Because I don't even have a clue how to compile luxrender. I can program but my experiences with compiling and things like that are very limited.

One other thing: When I export a scene which is using the OceanSim of blender 2.61 there is always a message in the log like '[2011-12-22 22:11:58 Warning: 43] Inconsistent shading normals in 904 triangles'.
What does that mean? Should I do something about it?

Btw: The last builds tend to produce some kind of white dots. (see picture - you need to load it completely to see them) I don't know whether this is a known issue related to jeanphis work. But maybe I'm just doing something wrong... (as usual. :( )
Attachments
OceanSim_lux_261stable.Scene.00009.jpg
HoloFan
 
Posts: 65
Joined: Sat May 14, 2011 7:04 am

Re: LuxRender 0.9-dev Windows build of 14-12-2011

Postby Lord Crc » Thu Dec 22, 2011 5:48 pm

HoloFan wrote:But when I start OpenCL Bidir (the preset 'OpenCL MLT & Bidirectional') not only luxrender but the whole PC crashes. My System is a Sony Vaio SB notebook with a AMD HD 6630M and my driver version is 8.862.4.3-110926a-126759C-Sony.


Sounds like a driver issue then, possibly due to hybrid bidir overallocating your hardware. A program shouldn't crash your entire PC.

HoloFan wrote:One other thing: When I export a scene which is using the OceanSim of blender 2.61 there is always a message in the log like '[2011-12-22 22:11:58 Warning: 43] Inconsistent shading normals in 904 triangles'.
What does that mean? Should I do something about it?


It means the vertex normals don't point in the same direction for a given triangle. It won't ruin your scene in this case I think, but I'd try lovering the "choppiness" parameter to 0.5 or below just in case.

HoloFan wrote:Btw: The last builds tend to produce some kind of white dots. (see picture - you need to load it completely to see them) I don't know whether this is a known issue related to jeanphis work. But maybe I'm just doing something wrong... (as usual. :( )


The white dots are most likely reflections of the sun, which is REALLY bright. Try using the "Gaussian" pixel filter instead of "Mitchell", also some slight bloom may be useful to cover them up.
May contain traces of nuts.
User avatar
Lord Crc
Developer
 
Posts: 4931
Joined: Sat Nov 17, 2007 2:10 pm

Next

Return to Weekly Testing Builds

Who is online

Users browsing this forum: No registered users and 1 guest