building on FreeBSD 7.2 fails

Discussion and help for Compilation problems and platform portability.

Moderators: Dade, coordinators

Re: building on FreeBSD 7.2 fails

Postby bany » Mon Sep 21, 2009 11:43 am

psor wrote:Wow, that's great bany! I'm wondering if you where crawling through all files. :o :mrgreen: ;)



take care
psor


actually a

find . -name '*' -print|xargs grep -i "pthread"

did the job ;)
bany
 
Posts: 15
Joined: Thu Sep 17, 2009 1:26 am

Re: building on FreeBSD 7.2 fails

Postby psor » Mon Sep 21, 2009 12:14 pm

It was ment metaphoric. Thanks anyway! :mrgreen: :mrgreen: ;)


take care
psor
"The sleeper must awaken"
User avatar
psor
 
Posts: 295
Joined: Mon Oct 22, 2007 7:16 pm
Location: Berlin, GER

Re: building on FreeBSD 7.2 fails

Postby bany » Mon Sep 21, 2009 12:43 pm

psor wrote:It was ment metaphoric. Thanks anyway! :mrgreen: :mrgreen: ;)


take care
psor


hahahahahahahahah :D :D :D sorry im obviously stressed :D
bany
 
Posts: 15
Joined: Thu Sep 17, 2009 1:26 am

Re: building on FreeBSD 7.2 fails

Postby psor » Mon Sep 21, 2009 1:24 pm

Enjoy the fact that you can compile and play with lux! :lol: :lol: ;)
And I wish you a lot of spare time for relaxation. :geek: ;)


take care
psor
"The sleeper must awaken"
User avatar
psor
 
Posts: 295
Joined: Mon Oct 22, 2007 7:16 pm
Location: Berlin, GER

Re: building on FreeBSD 7.2 fails

Postby bany » Fri Sep 25, 2009 6:29 am

uh.. in case someone faces the same problem, I also had to

ln -s /usr/local/bin/wxgtk2-2.8-config /usr/local/bin/wx-config

otherwise cmake complained it couldnt find wxwindgets (and hence no GUI)..
bany
 
Posts: 15
Joined: Thu Sep 17, 2009 1:26 am

Re: building on FreeBSD 7.2 fails

Postby psor » Fri Sep 25, 2009 8:13 am

Thanks for the hint, much appreciated! :mrgreen:



take care
psor
"The sleeper must awaken"
User avatar
psor
 
Posts: 295
Joined: Mon Oct 22, 2007 7:16 pm
Location: Berlin, GER

Re: building on FreeBSD 7.2 fails

Postby lq12 » Tue Oct 27, 2009 6:05 am

I also got a similar problem. But the OS is CentOS 5.4

LuxRender 0.6RC6 was running well on CentOS 5.3, but cannot be executed when the machine was updated to 5.4. I downloaded the LuxRender 0.6 Final and compiled it, but found an error in CMakeError.log:

/usr/bin/ld: cannot find -lpthreads

which made the "make" stops.

There is no "libpthread-stubs-0.1" installed, so should I install this library first?
lq12
 
Posts: 9
Joined: Tue Oct 27, 2009 5:39 am

Re: building on FreeBSD 7.2 fails

Postby lq12 » Tue Oct 27, 2009 12:28 pm

Sorry for my last poster. The problem is the version of Boost library. I have deleted the building of luxcomp in CMakeList.txt. And that works.
lq12
 
Posts: 9
Joined: Tue Oct 27, 2009 5:39 am

Re: building on FreeBSD 7.2 fails

Postby Dade » Wed Oct 28, 2009 4:31 am

lq12 wrote:Sorry for my last poster. The problem is the version of Boost library. I have deleted the building of luxcomp in CMakeList.txt. And that works.


It is a problem I have experienced on my Ubuntu too. It looks like cmake is buggy because even if you ask for a specific Boost version (i.e. 1.39) and you have multiple versions installed on your system, it picks the wrong one.
User avatar
Dade
Developer
 
Posts: 8404
Joined: Sat Apr 19, 2008 6:04 pm
Location: Italy

Previous

Return to Compilation & Portability

Who is online

Users browsing this forum: No registered users and 1 guest