Page 2 of 2

Re: Error - Ubuntu 8.04 (Hardy)

PostPosted: Wed Sep 16, 2009 6:01 am
by Seregost
:( Ok, I've tried to compile the 1.35.0 version of libboost, With the only result of breacking some other package in phyton so now neither blender runs :x I try to fix this problem and download the precompiled binary :cry:

Re: Error - Ubuntu 8.04 (Hardy)

PostPosted: Wed Sep 16, 2009 6:32 am
by Dade
Seregost wrote::( Ok, I've tried to compile the 1.35.0 version of libboost, With the only result of breacking some other package in phyton so now neither blender runs :x I try to fix this problem and download the precompiled binary :cry:


Compiling Boost libraries is a quite long task. I had about the same problem with some Debian installation (i.e. Debian 5.0 still includes an old version) but precompiled binaries are statically linked with Boost libraries and they work well even on system with old Boost libraries.

Otherwise you can just upgrade your Ubuntu to 9.0.4, it is an automatic and easy process ... and it will take about the same time required for compiling all the Boost libraries :shock:

Re: Error - Ubuntu 8.04 (Hardy)

PostPosted: Wed Sep 16, 2009 8:33 am
by pinko
Infact on my system works fine Blender and Luxrender... you see my PM Seregost???
And you Dade???
ciao
Luca. ;)

Re: Error - Ubuntu 8.04 (Hardy)

PostPosted: Wed Sep 16, 2009 2:15 pm
by Seregost
I cannot upgrade distro because there is a bug in newest kernel versions regarding my mobo :x
Bug report

I've also tried to install opensuse 11 but it doesn't support my DVD player, maybe the last chance is to change the DVD player and installing opensuse :D

Re: Error - Ubuntu 8.04 (Hardy)

PostPosted: Wed Sep 16, 2009 3:20 pm
by gagar
Ah the wonderful world of the mighty penguin! :lol: wink wink

Re: Error - Ubuntu 8.04 (Hardy)

PostPosted: Thu Sep 17, 2009 4:34 am
by Dade
Seregost wrote:I cannot upgrade distro because there is a bug in newest kernel versions regarding my mobo :x
Bug report


Quite unlucky, but the statically linked executable do not work for you ? It is the simpler solution if you don't want try to modify the latest sources on your own (the available rc6 binaries are only few days old).

Re: Error - Ubuntu 8.04 (Hardy)

PostPosted: Sat Sep 19, 2009 8:06 am
by Seregost
Ok, switched distro :roll:

On Fedora11 it works :D

Only some warnings. Those are only some of them, but all warnings was quite similar.

Code: Select all
In file included from /home/damiano/programmi/lux/core/sampling.h:30,
                 from /home/damiano/programmi/lux/core/camera.cpp:28:
/home/damiano/programmi/lux/core/contribution.h: In member function ‘bool lux::ContributionBuffer::Add(lux::Contribution*, float)’:
/home/damiano/programmi/lux/core/contribution.h:100: warning: comparison between signed and unsigned integer expressions
/home/damiano/programmi/lux/core/contribution.h:102: warning: comparison between signed and unsigned integer expressions

/home/damiano/programmi/lux/renderer/wxluxgui.cpp: In member function ‘void lux::LuxGui::ChangeRenderState(lux::LuxGuiRenderState)’:
/home/damiano/programmi/lux/renderer/wxluxgui.cpp:290: warning: enumeration value ‘PARSING’ not handled in switch


Notes. I don't now if it happens only on my pc, but the dependancies to install are to implement: boost-devel libtiff libjpeg
Hope this might be usufull for somone :)

Re: Error - Ubuntu 8.04 (Hardy)

PostPosted: Sun Sep 20, 2009 7:20 am
by Dade
Seregost wrote:On Fedora11 it works :D


Good :D

Seregost wrote:Only some warnings. Those are only some of them, but all warnings was quite similar.


It is ok, it happens with gcc. I guess we have to clean up them but they do not harm.

Re: Error - Ubuntu 8.04 (Hardy)

PostPosted: Sun Sep 20, 2009 11:18 am
by Seregost
Ha OK, thanks :D

Little OT, maybe someone now how to solve this issue: in Fedora, all works fine, but the 3D hardware accelleration doesn't want to work well. I've tried several ways to install GPU drivers without success. :roll: