Black Glass in Path OpenCL

Please use this forum for general user support and related questions.

Moderators: Dade, coordinators

Forum rules
Please include your operating system type/version, LuxRender version and Exporter version used when submitting a support post.

Make sure you have read the Release forum thread for Release and RC (Release Candidates) builds as these threads contain information on known problems and workarounds: Test Builds Forum

Black Glass in Path OpenCL

Postby delisun » Sat Jan 20, 2018 1:45 pm

Hello!

I just started using the LuxRender (the Version which is downloadable on the official Website) with Blender 2.79, but i got some Problems with the Render.

I created a Glass, used Solidify and Subdivision Surface Modifier. I used the standart Glass Material. The Mesh is absolut fine, no overlaping and all the Normals pointing outwards.

With Bidir Engine everything looks like expected
glass_bidir.png


But with Path Engine i got this massive Black error
glass_path.png



These were the Path Settings
lux_settings.jpg


And this is the .BLEND File
glassLux.blend
(554.82 KiB) Downloaded 52 times
delisun
 
Posts: 4
Joined: Sat Jan 20, 2018 1:25 pm

Re: Black Glass in Path OpenCL

Postby burnin » Sat Jan 20, 2018 3:04 pm

don't get the issue here, but i assume it could be remnants of water
to be sure, remove Water material from Glass object
burnin
 
Posts: 287
Joined: Mon May 03, 2010 8:04 pm

Re: Black Glass in Path OpenCL

Postby delisun » Sat Jan 20, 2018 4:01 pm

There is no water or water material. its only a glass with the standart glass material. The water material in the Blend File isn't asigned to anything and deleting it doesnt change anything.
delisun
 
Posts: 4
Joined: Sat Jan 20, 2018 1:25 pm

Re: Black Glass in Path OpenCL

Postby Dade » Sat Jan 20, 2018 4:28 pm

I have recently fixed/improved Glass material in v2.0, this was before:

old.png


and this after the fix/improvement:

new.png


and this is LuxCore Vs. classic Lux glass:

cmp.png


However, I'm not sure if you have hit this problem or another one: your glass seems really thin, it may be a numerical precision problem because the two surfaces of the glass are too near for the FP32 precision. Have you tried to repeat the a test with a thicker glass ?

P.S. I noteced you attached the .blend, tomorrow I will try how it works here.
User avatar
Dade
Developer
 
Posts: 8404
Joined: Sat Apr 19, 2008 6:04 pm
Location: Italy

Re: Black Glass in Path OpenCL

Postby Dade » Sun Jan 21, 2018 8:59 am

Dade wrote:P.S. I noteced you attached the .blend, tomorrow I will try how it works here.


It is working fine with v2.0alpha2 (if not something strictly related to your HDR which I think is not included in the .blend file):

glass.png


If you want, I can send you the information to access v2.0alpha2: viewtopic.php?f=12&t=13485
User avatar
Dade
Developer
 
Posts: 8404
Joined: Sat Apr 19, 2008 6:04 pm
Location: Italy

Re: Black Glass in Path OpenCL

Postby burnin » Sun Jan 21, 2018 11:57 am

Had mentioned 'Water' removal because the original file crashed immediately, if only render was started.
The second time issue showed up for a moment only in preview.
After looking at inner workings i saw 'Water' mat., i concluded it was remnant from some past doings (i assumed - water in a glass) so to be sure i removed it & recalculated normals. Since then it's working fine with 1.7...

Image
burnin
 
Posts: 287
Joined: Mon May 03, 2010 8:04 pm

Re: Black Glass in Path OpenCL

Postby Dade » Sun Jan 21, 2018 2:11 pm

burnin wrote:Since then it's working fine with 1.7...


I think Delisun is using the last available official v1.6 release that unfortunately is very very old now.
User avatar
Dade
Developer
 
Posts: 8404
Joined: Sat Apr 19, 2008 6:04 pm
Location: Italy

Re: Black Glass in Path OpenCL

Postby delisun » Mon Jan 22, 2018 7:37 am

in Blender Addons the version is 1.7 dev. I found out the problem only appears in LuxCore, if i go for Classic API i get no issues.
delisun
 
Posts: 4
Joined: Sat Jan 20, 2018 1:25 pm

Re: Black Glass in Path OpenCL

Postby burnin » Mon Jan 22, 2018 11:44 am

Take a look here (latest LuxCore 1.7 SDK binary for Windows + couple of posts below latest LuxBlend is posted), see if those work for you too...
burnin
 
Posts: 287
Joined: Mon May 03, 2010 8:04 pm


Return to LuxRender User Support

Who is online

Users browsing this forum: No registered users and 2 guests