Luxball7 - LuxRender Material Preview Scene

General Project and community related discussion.

Moderator: coordinators

Luxball7 - LuxRender Material Preview Scene

Postby Rhys » Fri Jun 14, 2013 12:13 pm

Luxball7

This is the latest release of the LuxRender material preview scene. You may find downloads at the bottom of this post.

Update notes;
I've reworked the ball mesh again.
Idea was to make the mesh more clean and uniform, also to remove seams from UV map and trade for a bit of texture stretching.

The end result now does not need subdividing at all and doing so brings very little visual difference anyway (it can be subdivided for displacement). Because of not requiring a subsurf for a final step the scene triangle count has reduced by about 100k. (148k triangles vs 247k) (although this does mean the file size has increased slightly)
Due to more uniform grid and removal of seams around the logo, displacement should function nicer. Besides that, a uniform grid just looks cool.
Ball retains its near perfect reflections from luxball6.
luxball7.jpg



I have created a new cloth (sorry), this time it is included in the same .blend and can be toggled with the visibility.
cloth.jpg


Some other things I've done is to remove the 6500k blackbody texture from the lamps, this emitted an ugly pink hue. Instead the lights are simply white and the render white balance is very near perfectly neutral.
-Base ring UV mapping scale was made consistent and stretching fixed.
-Default tonemapping ISO was changed to 300 instead of 500 which was overexposed for some reason.
-Camera has been zoomed to 85mm instead of 80mm
-Cleaned up some namings in the .blend file
-Fixed glossy material specular colour to not be at 0.2, instead set it to 0.04.
-I have set "keep-UI" for blender render mode
-Noise-aware on

I also fixed up some old SPPM settings in-case someone whishes to render a glass material with SPPM. (and SPPM performs this scene extremely well in general anyway)
-SPPM lookup accelerator setting has been changed from "kd-tree" to "hybrid hash grid"
-Photons per pass changed from 10000 to 150000

If you have any file conversions please post them in this thread and we will happily attach/link them to this top post.


LuxRender scene .lxs
luxball7_lxs.zip
(5.25 MiB) Downloaded 152 times


Blender .blend
(when opening the blend file you will need to update the output paths and path to LuxRender engine in the render settings.)
luxball7-blender.zip
(4.1 MiB) Downloaded 183 times
Last edited by Rhys on Sun Jun 16, 2013 2:57 am, edited 5 times in total.
Rhys
 
Posts: 749
Joined: Fri Mar 06, 2009 5:40 pm
Location: Australia

Re: Luxball7

Postby tomb » Fri Jun 14, 2013 1:32 pm

That's just wonderful work Rhys! Thank you :)
User avatar
tomb
Developer
 
Posts: 2405
Joined: Thu Oct 11, 2007 4:23 pm
Location: Oslo, Norway

Re: Luxball7

Postby Lord Crc » Fri Jun 14, 2013 2:49 pm

Great work Rhys!

I took the liberty of splitting the old topic, it was getting unmanageable. The old luxball5 thread is here: viewtopic.php?f=13&t=5527
May contain traces of nuts.
User avatar
Lord Crc
Developer
 
Posts: 4931
Joined: Sat Nov 17, 2007 2:10 pm

Re: Luxball7

Postby B.Y.O.B. » Fri Jun 14, 2013 4:41 pm

Little nitpick: the path to the grid texture is not relative, it's pointing to some "E:\..." path.

updated version: relinked paths, set integrator from "path" to "bidirectional".

Btw. the scene doesn't run with SLGPathOpenCL for me (Windows 7 64bit, Radeon 7970 GHz). Luxrender crashes at the point where the log (verbose) says "compiling kernels...".
Can someone confirm this?
Attachments
luxball7_BYOB.zip
(4.11 MiB) Downloaded 55 times
User avatar
B.Y.O.B.
 
Posts: 2153
Joined: Wed Nov 10, 2010 4:10 pm
Location: Germany

Re: Luxball7

Postby A-man » Fri Jun 14, 2013 5:22 pm

Geez Rhys, will it ever be perfect enough?! Just kidding, great job, it looks fantastic! :)
i7 3770k 3.5 GHz | 16 GB RAM | Radeon 7970 3GB
User avatar
A-man
 
Posts: 722
Joined: Sat Apr 24, 2010 4:24 pm

Re: Luxball7

Postby Rhys » Fri Jun 14, 2013 11:23 pm

Great!
Lord Crc wrote:I took the liberty of splitting the old topic, it was getting unmanageable. The old luxball5 thread is here: viewtopic.php?f=13&t=5527

Thanks, can you unstick the old old ""'luxball' Default Material Preview Scene"" thread?

B.Y.O.B. wrote:updated version: relinked paths, set integrator from "path" to "bidirectional".

Whoops, fail :x thanks,

I uploaded your fix to the top post, also removed the 'untitled' grid image I had in the file.
Rhys
 
Posts: 749
Joined: Fri Mar 06, 2009 5:40 pm
Location: Australia

Re: Luxball7 - LuxRender Material Preview Scene

Postby Piita » Sat Jun 15, 2013 2:52 am

Excellent work Rhys!
User avatar
Piita
 
Posts: 210
Joined: Sat Aug 06, 2011 2:09 pm
Location: Finland

Re: Luxball7 - LuxRender Material Preview Scene

Postby SATtva » Sat Jun 15, 2013 4:39 am

Agreed with all colleagues, thanks for your efforts Rhys.
Linux builds packager
聞くのは一時の恥、聞かぬのは一生の恥
User avatar
SATtva
Developer
 
Posts: 6085
Joined: Tue Apr 07, 2009 12:19 pm
Location: from Siberia with love

Re: Luxball7

Postby Dade » Sat Jun 15, 2013 9:46 am

B.Y.O.B. wrote:Btw. the scene doesn't run with SLGPathOpenCL for me (Windows 7 64bit, Radeon 7970 GHz). Luxrender crashes at the point where the log (verbose) says "compiling kernels...".
Can someone confirm this?


I will check with my PC but there is some material combination that can not still be compiled on AMD GPU because the driver runs out of memory (no matter how much memory you have). As cross check, to detect this kind of problems, you can just try to render with OpenCL CPU device alone (if it works, it is usually a good hint that there is a problem on GPU driver).
User avatar
Dade
Developer
 
Posts: 5866
Joined: Sat Apr 19, 2008 6:04 pm
Location: Italy

Re: Luxball7 - LuxRender Material Preview Scene

Postby B.Y.O.B. » Sun Jun 16, 2013 1:20 pm

Dade wrote:As cross check, to detect this kind of problems, you can just try to render with OpenCL CPU device alone (if it works, it is usually a good hint that there is a problem on GPU driver).

It doesn't work with CPU device either.
But it works if I change all materials to matte manually, remove textures etc.

edit: it works if I remove the gridfloor texture ... or no, wait, it's not only that :|

edit2: it works if I move all parts of the luxball to another layer. When I put back only one part (like the bubbles or the stand etc.) it crashes again.

edit3: the luxball with clay material renders fine. The following materials crash Luxrender: "stand text", "luxball stand", "bubbles".
User avatar
B.Y.O.B.
 
Posts: 2153
Joined: Wed Nov 10, 2010 4:10 pm
Location: Germany

Next

Return to General Discussion

Who is online

Users browsing this forum: No registered users and 8 guests