LuxRender v1.3RC2

News & Announcements regarding releases, features, exporters and project coordination.

Moderators: Dade, coordinators

Re: LuxRender v1.3RC2

Postby SATtva » Mon Oct 07, 2013 8:07 am

Labello wrote:
I see you're using boost 1.54, we've not tested this version of boost and there could be issues with it, unless someone else can confirm it is working.
Are you compiling LuxRender yourself or do you use a precompiled binary?


I used the precompiled binary from the download section.

Official Lux builds (including the Linux one) are compiled against Boost 1.47.

What about Blender? Is it an official build from blender.org, or a custom build from graphicall.org, or a build from your Linux distro? Can you test with the official Blender build?
Linux builds packager
聞くのは一時の恥、聞かぬのは一生の恥
User avatar
SATtva
Developer
 
Posts: 7164
Joined: Tue Apr 07, 2009 12:19 pm
Location: from Siberia with love

Re: LuxRender v1.3RC2

Postby Labello » Mon Oct 07, 2013 8:13 am

I am using Blender as provided by my distro. Since Arch tends to compile vanilla packages as intended by the developers this should not be any probable issue.

Currently I am building luxrender from the cutting edge code. I will report back how it turns out. :)
// Blender 2.68a // Archlinux // AMD X4 2800 // Nvidia Geforce 240 GT //
"They say just hold onto your hope but you know if you swallow your pride you will choke"
Alexisonfire - Midnight Regulations
User avatar
Labello
 
Posts: 168
Joined: Tue Jan 29, 2008 1:32 pm

Re: LuxRender v1.3RC2

Postby Lord Crc » Mon Oct 07, 2013 8:19 am

Labello wrote:Currently I am building luxrender from the cutting edge code. I will report back how it turns out. :)


Make sure you build LuxRender against Boost 1.47 or .48 (though with 48 you might have network rendering issues if you try). Any higher and you're running the risk of having issues.
May contain traces of nuts.
User avatar
Lord Crc
Developer
 
Posts: 5032
Joined: Sat Nov 17, 2007 2:10 pm

Re: LuxRender v1.3RC2

Postby SATtva » Mon Oct 07, 2013 8:36 am

Labello wrote:I am using Blender as provided by my distro. Since Arch tends to compile vanilla packages as intended by the developers this should not be any probable issue.

From the error you reported earlier it's clear some package in the chain is compiled with Boost 1.54. If you're using Lux from a prebuilt package provided on this site, i'm confident that something is wrong with Blender as provided by your distro. Once again, i strongly suggest you to run Lux with the official Blender build from blender.org to confirm or eliminate this variable.
Linux builds packager
聞くのは一時の恥、聞かぬのは一生の恥
User avatar
SATtva
Developer
 
Posts: 7164
Joined: Tue Apr 07, 2009 12:19 pm
Location: from Siberia with love

Previous

Return to News & Announcements

Who is online

Users browsing this forum: No registered users and 1 guest